How to move the root directory of the new Opera Mail , the stand alone mail client ?

  • I know there is a thread on that topic but using the search function doesn't show it up here. So i re-iterate the question.
    I'm using Opera Mail V1.0 build 1040 Win32 OS Win 8. Not that I wanted it this way, but with the last opera-upgrade all of a sudden the browser and the emailclient were separated 😞
    Now, I would like to move the root directory for the mail ("Opera Mail") to a new directory ("OPERA") on a new partition ( E:\ ). The new path would thus be : E:\OPERA\Opera Mail
    I did put the statement "Mail Root Directory=E:\OPERA\Opera Mail" in "operaprefs.ini" under "[User Prefs]" , but to no avail 😞 What did I do wrong ? And most important : what and how should I do it ??
    Thank you in advance for an expert answer.

  • Try:

    [Mail]
    Mail Root Directory=E:\OPERA\Opera Mail
    

    instead of putting it under user prefs.

  • Thx. But when I do this, I need to start up anew.I did choose "import email". I then was asked to give the file with the "account.ini" .This file is located at " C:\Users\myName\AppData\Local\Opera Mail\Opera Mail\mail\accounts.ini ". But when I try to fill this in, I get the answer "invalid path". So I'm stuck ! Note : I opened as administrator with full rights.

  • Just move your old Mail folder to the new one, there's no need to import your messages.

    But when I try to fill this in, I get the answer "invalid path".

    You need to set up your Windows to show hidden files and folders. You do it in Windows Explorer.

  • http://windows.microsoft.com/en-us/windows/show-hidden-files#show-hidden-files=windows-7

    Also, make sure to uncheck "hide extensions for known file types".

  • Thx but my OS is Win 8 and IE was and is set to show hidden folders. That could thus not be the reason.

    May I reiterate my request ?
    I'm using Opera Mail V1.0 build 1040 Win32 OS Win 8.
    On C:\Users\MyName\AppData\Opera Mail I have 29 Giga B (sic ) of mail.
    I now would like very much to move this huge file away from 😄 to E:\OPERA\Opera Mail
    But just setting the new wanted path in operaprefs does not work, be it under users prefs or not.
    How should I do it ??

    Thx in advance.

  • But just setting the new wanted path in operaprefs does not work, be it under users prefs or not.

    Have you moved your mail folder to the new location? The setting is just to say to Opera to look for your mail in that location, it will not move the files.

  • Yes I did so. But then I saw that the new messages did not go to this new file but that the - not yet deleted - mail-folder in 😄 was updated. I did not want to delete this original folder in 😄 as long as I was not quite sure about the correct function of the new one on E:. 29 GB is a hell of a mass to loose 🙂

  • I did not want to delete this original folder in 😄 as long as I was not quite sure about the correct function of the new one on E:

    You can make a backup of the folder just in case Opera were to destroy it at the new location. But, it shouldn't.

    Make sure you're editing operaprefs.ini while Opera is closed and as said, make sure you move "C:\Users\myName\AppData\Local\Opera Mail\Opera Mail\mail" into "E:\OPERA" so that it's at "e:\OPERA\Opera Mail" and that there's not a mail folder at the old location.

    Also, make sure the E drive is always available and ready before you start Opera. Otherwise, there could be an error and Opera might use the default location on C.

    my OS is Win 8

    There should be no difference compared to Win7 for how this all works.

  • I did move "C:\Users\myName\AppData\Local\Opera Mail\Opera Mail\mail" to E:\Opera . So there was no longer this file in 😄
    and put "Mail Root Directory=E:\OPERA\mail" in operaprefs.ini
    Starting operamail then opens the wizard new account ! But I do not want a new account !!!
    What went wrong ??

    Thx

  • What went wrong ?

    Opera's not finding the mail folder in that location and is using the default location. Is omailbase.dat at "E:\OPERA\mail\omailbase.dat" and accounts.ini at "E:\OPERA\mail\accounts.ini" when Opera Mail starts up? In some situations, if you've been upgrading for a long time, your mail will actually be in another "mail" folder inside the "mail" folder.

    Is the mail root directory line under the [Mail] section in a operaprefs.ini? Also make sure there are not 2 Mail Root Directory lines (although Opera should remove extra ones). Also, make sure you're not using quotes on that line.

    You might want to also retype the whole line in the file.

    Also, although it shouldn't matter, make sure you're windows newline format when editing operaprefs.ini.

    Also, you are indeed editing "C:\Users\user\AppData\Roaming\Opera Mail\Opera Mail\operaprefs.ini" and not "C:\Program Files (x86)\Opera Mail\operaprefs_default.ini", correct?

    Also, each time you attempt to get it to work right, delete the new email folder Opera creates *in* "C:\Users\user\AppData\Local\Opera Mail\Opera Mail".

    Just for the hell of it, maybe try E:\Opera Mail\mail for the path. It shouldn't matter, but...

    Is the E drive formatted as NTFS instead of FAT32? It shouldn't matter as long as the files in the mail folder are small enough etc., but reformat the drive as NTFS (backing up things first if possible) if needed.

    Also, search the whole 😄 drive (and the E drive is there's a lot on it) to see if you can find another "mail" folder. Searching for omailbase.dat might be good enough. If the path that Opera reads from operaprefs.ini gets messed up for some reason, Opera might create the new mail folder somewhere else. This doesn't sound like the case given Opera keeps creating a new mail folder in the default location. But, I'd check anyway.

    What type of drive is E:?

  • Well, first of all, thank you so much burnout426 ! Sure you're not yet burned out ! It seems to work smoothly now - except for the one tricky problem that is handled in another thread.
    What did I have to do :
    1- delete the newly created folder in "C:\Users\user\AppData\Local\Opera Mail\Opera Mail".
    2- Put the mail root directory line under the [Mail] section in a operaprefs.ini, rather than under "Users preferences "as I did first.
    All other conditions were OK. And my E-drive is a 500GB partition on a big 2T HDD.

    Thanks again and see you at the next problem 🙂

  • Glad you got it!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.