Search results are in Turkish

  • All my search results are in the Turkish language. Can anyone explain why this is occurring, and how I change it to English? It is really annoying!

  • Edit the file Local State in a text editor and look for those lines:

    "location": {
          "country": "",
          "country_from_server": "",
    

    Change the values of country and country from server to your country's code.

  • Where do I find this file? What folder is it in? I did a search in the opera folder, and it did not come up. There is a "locale" folder that appears to contain folders for different countries, but nothing like you describe.

  • Take a read in this thread for where to find Opera folders.

  • Where do I find this file? What folder is it in?

    See OMenu > About Opera for the path to Opera's profile folder.

  • OK, I found the file, but the location already says U.S, so this is not the cause of the search results being in Turkish.

  • Where is your server?
    Having a localised version and being in Russia, I still have .com there - though Russian is nevertheless "grey-preset" in the results languages...

    All my search results are in the Turkish language. Can anyone explain why this is occurring, and how I change it to English?

    Most probably you can still add English to your results languages - via the Google search settings there.

  • Server is in Illinois, USA. I also have English as my preferred language under browser settings.

  • What's your Opera?
    If Presto, you can try resetting your Google se. If Blink - there's a way people talked about - to delete the Gse somewhere in your Opera files:idk:
    Are you sure you didn't install a Turkish Opera? Or maybe you did it being in Turkey? Or used a proxy there?

  • The problem happens in all search engines?

  • Actually, to my surprise, it only seems to happen with google, not with Bing or Yahoo. But I do not have the same problem with Chrome.

  • Are you using Google being signed in - in Opera? in other browsers?
    Any differences?

  • How do you sign in with google when using Opera? Yes, I am signed in with google when using chrome, and no results in Turkish when using chrome.. I also do not have this problem with firefox and google search (not signed in and seldom use).

  • You can set Google to use a default language - whether or not you are signed in. If you are not signed in, the obvious choice is to go to Settings > Privacy & security, click on "All cookies and site data" and then delete Google-related cookies. If you were signed in, that might have too many side effects (most notably signing you out) so you'd be better off going to Google, clicking on their Settings link, then Search settings, then Languages (or just click here) and choose the correct language.

  • OK, this fixed the problem thanks.

  • How did you go Turkey in the first place?
    [ 🙂 ]( "Pun is intended.")

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.