:tools: Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, December 14, starting from 10:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

Very slow for certain site

  • I have been using Opera for awhile now. The site in question is not usually a problem but since last night and today it is possible to access it, eventually, but it's EXTREMELY slow. Pretty much useless.

    The site in question is a discussion forum, here:

    http://discuss.joelonsoftware.com/default.asp?biz

    Sometimes if I tell Opera to STOP loading, the page will suddenly appear. Generally it just keeps returning a blank white screen, eventually loading the page after around 7 minutes or so.

    I have tried disabling Malwarebytes malicious page block - no difference.
    I have tried clearing Opera's cache - no difference
    I rebooted - no difference
    As this is a new PC I tried resetting the DNS servers to Google's 8888 - no difference
    I've tried disabling the only 2 extensions in Opera, Roboform and Adblock - no difference
    I've tried uninstalling Opera and reinstalling it - no difference

    Finally, in desperation, I tried Internet Explorer. The site loads fine in IE, so it's not the site or my connection.

    The problem is with Opera. So any ideas how I can fix this? Or can you provide a link so I can download an earlier version which works?

    Thanks.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.