downloading mp4 as ogg?

  • opera 12.17 64 bit.
    When I right click on an mp4 link and "save as" opera is saving it as an ogg file, which will not play as a video.
    The 32 bit version works fine so I assume it is a settings difference.
    Looking in my preferences->advanced->downloads mp4 should be saved as mp4. So I have no idea why it isn't.
    Any advice?

  • It depends on what file type the website says it is. You can always rename the file - all that was changed was the extension. But look to see which types it thinks should have an extension of "ogg" and see if they look reasonable. (I only have 4 types - after clearing "Hide file types opened with Opera" - and they are all obvious ones.)

    Alternatively give us a link and we'll see what the server actually says it is.

  • When I copy the link it is an mp4, when I click "save as" it is as an ogg, and it is converted, renaming it does not work.
    It is all mp4 files not just a particular site. There are three test files on this link, hover over each one and it gives the correct extension, click 'save as' and it is an ogg. Except the ogv, that one is saved correctly.

    https://archive.org/details/Pbtestfilemp4videotestmp4

  • Saves as mp4 for me...

  • Yep!, saves as mp4 for me too.

  • So it works for you. How does that help me?

  • So it works for you. How does that help me?

    It means that the problem may be on your end.

    It happens on all pages or just on a specific one? Other files are downloaded with their correct extensions?

    Try with a clean Opera profile (rename operaprefs.ini) and see if it works correctly.

  • I have already said the problem is at my end and that it is all pages and just mp4. Anyway I have figured it out. I am using the extension Imagus by Deathamns, when I disable it everything behaves as it should.

  • According to web sniffer and dragonfly, https://archive.org/download/Pbtestfilemp4videotestmp4/video_test.mp4 has a content type of video/mp4. But, it's 302 moved permanently and redirects to https://ia902302.us.archive.org/27/items/Pbtestfilemp4videotestmp4/video_test.mp4. However, that has a content-type of video/mp4 also.

    So, in Opera's file type settings, make sure video/mp4 as the mp4 extension listed for it. Also, make sure the oga, ogv and ogg types don't have mp4 has an extension unless you're working around a site that sends mp4 files as that type.

    If that's correct and it still doesn't work, I'd investigate extensions, User JS and proxies. If none of that helps, close down Opera and goto the preferences folder. See help -> about Opera for the location. Delete handlers.ini if present to reset all your download and file type preferences. Also, in operaprefs.ini, if you see mime type settings, delete those lines so Opera uses the default. Also, make sure you see the following sections and settings in opearprefs.ini.

    [Trusted Protocols Section Info]
    Version=1
    [File Types Section Info]
    Version=3
    

    Also, goto opera:plugins and make sure that any plug-in that supports mp4 is disabled. Or, at least make sure "use plug-in" isn't selected for video/mp4 in Opera's file type settings (the plug-in will still be used for embedding even if "use plug-in" isn't selected. Selecting "use plug-in" will just control what happens when you visit the link directly).

    If none of that helps, hit ctrl + j to get to downloads and enter the mp4 link in the quick download file. In Opera, that's like a non-nonsense download method that may work better.

    Also, in opera:config, there's a "Trust Server Types". The default is unchecked, but you can try to check (and save and restart) if you want to see if that helps.

  • I went through what you posted. Changed the mp4 type to 'open download dialog' now when I click on it (not right click) it opens the dialog which saves the file in the correct format

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.