Opera doesn't like Fullscreen.

  • High got a small but annoying issue. Whenever i start opera it starts in a small window instead of "maximized" to fullscreen. Which i usually use. I don't seem to find a way to fix it.

  • Having same problem with both 25 and 26. In 24, there is a section to adjust screen size in the Preferences, but this option isn't available in 25 and 26. What is interesting is that 25 opens fullscreen on my laptop and DOES have the screen sizing options in the Preferences.

  • I figured it out!! When Opera opens to the smaller window, there will be only the fullscreen icon on the top right, in the middle. Rather than clicking it to expand, use the cursor to drag the screen to the desired fullscreen size, then you can click the middle icon to maximize. Then, close Opera. Navigate to C:\users(your folder)\AppData\Roaming\Opera Software\Opera Next (or Developer). Then open the Prefences file with Notepad. The first section should look like this:
    {
    "browser": {
    "last_clear_browsing_data_time": "13055961354714955",
    "window_placement": {
    "height": 1050,
    "left": -3,
    "maximized": false,
    "top": 0,
    "width": 1926
    }

    Note the line "maximized": false, Change false to true, then save file. Restart Opera and it should open in fullscreen mode!!

  • Which Opera build and which OS? I don't have such problems on Win8.1.

  • 25.0.1614.18  and 26.0.1632.0  Windows 7 Home Premium
  • @ chawoobie

    thx that worked. BTW you don't need to drag it manually it's enough to set maximized to true. However it won't start as window anymore. It would be perfect if it started the way i closed it. Guess this needs a fix.

  • Glad to help. However I found that the option to set maximum to true wasn't present in Preferences unless I manually resized it first.

  • At least here, if Opera is closed maximized then it will be reopened on that state.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.