Opera crashing "out of memory" when lots of memory still available

  • Hello, I'm using Opera on Win 7 64 Bit,
    with 4gb of RAM. I have the paging file disabled for security reasons.
    Opera keeps crashing due to out of memory error, when I still have
    over 1gb of free unallocated RAM. I check the task manager and Opera runs numerous
    processes when I'm only using one window. Why is this and why can't I use the
    remainder of my RAM for Opera? Is there more way to allocate memory to Opera?
    And can I disable some opera features that would free up some RAM?
    Thanks

  • ...with 4gb of RAM. I have the paging file disabled...

    Oh my :rip:

    Opera keeps crashing due to out of memory error...

    It will...

  • @joshl, what's the big deal? Opera crashes even before using 1gb of RAM, there's a whole other GB available that it could be using. So what's the deal? Can I allocate more memory to Opera? I don't see a reason why Windows should reserve 1 gb for nothing.

  • Surely this is a Windows memory problem ?, As it seems to be starving Opera of the RAM that it requires. Have you tried turning off resource eating effects (transparency and transition effect) and programs that start up with Windows ?. Maybe running Opera on its own (with on other programs running) or only opening a minimal amount of tabs ?.

  • Did you read the blog I linked to?
    Anyway, as I see it, it's not an Opera issue: if you believe Windows should behave differently, you should resort to Microsoft's support...

    [ :pssst: ] Linux, it's possessive is its:P [/:pssst:]

  • Did you disable pagefile for privacy reasons?

    Then encrypt teh pagefile: http://wiki.gonzofamily.com/a/Ms_Windows_Pagefile_and_Privacy ;)

  • Thanks for the advice guys, but still doesn't answer my question of why this is happening. Is this a fault of Windows or Opera? If it's Opera the developers should fix this bug.

  • And if it's Windows ?.

  • Is this a fault of Windows or Opera?

    It's not the fault but configuration of Windows. You'd need an astronomical RAM and still to watch what you're doing in order to use Windows with the 0 pf. Any "greedy" app will crash otherwise.
    NuOpera is a multiprocessing app, and EACH process reserves a certain space in RAM, and the OS reserves some place in its virtual memory... If it can find one...
    The guys built the system for years, so why do you think someone can just dismiss an element as "redundant"?
    There's used space and there's space in use. There are differences...

  • Just a (late) comment: I'm running Windows Server 2008 R2 with 16 GB RAM and a 16 GB pagefile. I'm still getting the "Out of memory" error in Opera (v27) from time to time, even when the amount of free RAM is 10 GB or more. So the problem might not be the lack of a pagefile or Windows running out of free memory.

  • @peroen

    This should not happen on a OS with such large ressources.

    Please report this as a bug at https://bugs.opera.com/wizarddesktop/ and add crashdump files/information

  • 16 gigs of RAM here. I regularly keep Opera running for days, even weeks, and have had upwards of 400 tabs going at once and never gotten such an error.

  • I'm sorry I have to disagree with all of you (apart from forum2233) as I have the same problem.
    Stop blaming Windows please that is not the issue. On the same system that Opera is giving an 'Out of Memory' error I also have Firefox, Chrome and even IE - Yes that's right all of the other browsers are working just fine.

    Stop pointing the finger and realise that there is a problem with Opera - yes that's right, as difficult as is is to believe here in forums.opera.com land it still has problems. Stop burying your heads in the sand and please stop thinking it's perfect. Stop blaming the operating system even though it's Windows (lol, oh how funny we all use Linux here smarmy land) and deal with the problem at hand.

    Mr. Lando242 with your 1013 posts, if you have Opera with over 400 tabs open and everything is running for weeks then you're a ....

  • Mr. Lando242 with your 1013 posts, if you have Opera with over 400 tabs open and everything is running for weeks then you're a ....

    Mad or jealous, I can't decide which...

  • I check the task manager and Opera runs numerous
    processes when I'm only using one window.

    Extensions, add-ons, plug-ins use memory. Do you use a lot of those? Opera divides it's processes up, so that if one thing crashes, the browser doesn't. So each extension, plugin, etc. uses a different process. If they all used the same process, you'd have more ram being used in that one process, and if anything went wrong, the browser would crash. So the separate processes are, it's my understanding, user-friendly. Of course, if you use a lot of tabs, that takes memory. Do you have other programs working in the background besides Opera. That can be taking up memory. Also, there could be, it's my understanding, memory leaks from malware, viruses. Etc. You need to check for that.

    If other browsers like Opera, eg., Chrome, (which is the most alike), Firefox, IE) don't have the out-of-memory problems, (which is what @scifisi suggests) (but it's up to the original poster to test it for his situation), then that would suggest to me something with the Opera setup that is causing it.

  • Go to the Control Panel, System, Advanced Proprieties, Performance. One of the buttons will lead you to the virtual memory settings. It should be enabled to at least onf of your SSDs/HDDs. Set your virtual memory size to "Defined by system", apply and restart.

    Mame sure you have this setting to be defined by system and that you have enough free space in your SSD/HDD.

    Only then, come here to tell us whether the issue remains.

  • Some programs need to have a swapfile, regardless of how much RAM is fitted.
    IIRC some Adobe programs used to be notorious for this, they just wouldn't work if there was no swapfile available.
    If you're worried about security with a swapfile, and you're comfortable with editing the registry, navigate to
    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
    and set the "ClearPageFileAtShutdown" entry to "1".
    The usual caveats about backing up first apply of course!
    :)

  • have you check the Opera.exe processes on your Windows task manager on your computer.

    if not, then go to task manager on your computer, then go to processes,then right click on one of the Opera.exe process, then go to "Set Priority", and their should be a list of priority, with "Low" the lowest and "Real Time" the highest. and if it's set to "Low", then select "Normal" to that process.

  • I wouldn't blame this on Windows. It's been happening to me on my iMac for the last few months. About to give up on Opera.

  • Keep in mind that Opera is a 32-bit program in Windows. Without a pagefile to give it virtual memory, it is limited to 2 GB - some of which is used by plugins and Windows itself. Not that Opera shouldn't run in 2 GB if you don't get carried away, but you are limiting yourself there.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.