Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • @leocg any tutorial for that please?

  • This thing keeps eating memory and cpu making the browser sluggish and unresponsive. please let us disable this crap

    alt text

  • @emanuel1788 The easiest way would be to download and install an older build and block autoupdate, but you can also edit installation_status.json so that it point to the older version folder.

  • @leocg thank you ill try

  • Hello,

    I love Opera since the introduction of Workspaces and since there is no other browser that does this (not to my knowledge anyhow) I tried to end process of the Cash Back Web Monitor several times and it seems that after 3 times it doesn't start anymore (until the next opera open action 😛 )

    So I did like this:

    1. Open Opera

    2. Press Shift +ESC (this will open Opera's Task Manager)

    3. Sort Task by name (to find Cash Back Web Monitor )

    4. Click Cash Back Web Monitor

    5. Click End Process (which is found on the right bottom corner)

    6. Let it restart again

    7. Click Cash Back Web Monitor

    8. Click End Process (which is found on the right bottom corner)

    9. Let it restart again

    10. Click Cash Back Web Monitor

    11. Click End Process (which is found on the right bottom corner)

    I hope this will work until the new version will fix it. I have the OPERA opened for 10 minutes now and it didn't start again.

    Cheers

  • To Opera we're only shoppers now. This is what it is, when it's free you are the product. Thanks for all those years, but this is the last straw. Going to Firefox.

  • I'm having the same problem as well. Opera's CPU usage climbs slowly and steadily over time until it starts lagging my entire computer, at which point I have to restart it. I'm on Opera v74.0.3911.203, running an intel i5 9800F on 64-bit windows 10.

  • @eddieu

    @eddieu said in Addons "Cashback Web Monitor":

    Hello,

    I love Opera since the introduction of Workspaces and since there is no other browser that does this (not to my knowledge anyhow) I tried to end process of the Cash Back Web Monitor several times and it seems that after 3 times it doesn't start anymore (until the next opera open action 😛 )

    So I did like this:

    1. Open Opera

    2. Press Shift +ESC (this will open Opera's Task Manager)

    3. Sort Task by name (to find Cash Back Web Monitor )

    4. Click Cash Back Web Monitor

    5. Click End Process (which is found on the right bottom corner)

    6. Let it restart again

    7. Click Cash Back Web Monitor

    8. Click End Process (which is found on the right bottom corner)

    9. Let it restart again

    10. Click Cash Back Web Monitor

    11. Click End Process (which is found on the right bottom corner)

    I hope this will work until the new version will fix it. I have the OPERA opened for 10 minutes now and it didn't start again.

    Cheers

    this actually works. thanks

  • Ok, first I really want to Thank the original poster and other members of this thread who just saved me from insanity. An UI I'm developing makes heavy use of both the Tradingview chart embedded module and the websockets, which were mentioned above as the "cashback monitor" triggers. I noticed that the UI started to freeze often lately and spent a couple of days profiling memory usage left and right until I spotted that satanic beast in the Task Manager (apparently, the only place in the browser where technically inclined users may accidentally notice it). Now, my UI consumes quite a bit of resources because of some heavy calculations, but this thingy beats it in just few minutes:

    alt text

    And yeah, even after you kill it, it keeps rising from the hell as a pesting zombie. What a marvellous decision to improve your users experience, Opera!

  • @curiouscroc Found a solution, installed the Vivaldi browser, how ironic! 🤣

  • Same issue, seems to be related to using trading platforms like "binance" that use "tradingView" live graphs.

    Had no issue with this a week ago.

    I'll be switching to another browser in the mean time.

    Hopefully Opera can fix this quick enough before I settle into a new browser.

  • This post is deleted!
  • 74.0.3911.218 has solved the issue. Cashback Web Monitor extension is not even running anymore.
    Vivaldi is good browser but UI lags so much compared to Opera to the point I can't stand it 🙂

  • @winblood The switch is not an option because of the devtools. I love Opera as a Chrome clone without the Big G attentive "addons" 😉 so just downgraded back to 73.0.3856.344 for now.

  • @curiouscroc Well now Opera is profiling you with their internal plugins that you cannot disable. Big G attentive behavior much.

  • @winblood as mentioned above the 74.0.3911.218 release solves the issue.

  • @winblood Internal extensions have been there since a long time.

  • @curiouscroc Vivaldi is chromium based as well, same devtools.

  • @andrew84 The fact that it was shadily activated is questionable practice. It could be a bug indeed, but seriously, do people need such services for shopping? Looks like Opera is being capitalized, and I don't like/trust it.

  • @leocg Fine, but let me choose which ones i want to run.