Can't delete login autofill

  • even when I delete "all private data", I can only disable the autofill, but once I enable it I can't delete old logins I don't need. this is incredibly frustrating and I'd be happy to hear any suggestions

  • Version? The answer is different in 12.x and earlier than in 15+ ...

  • the latest release, whichever one that is. run on Win7

  • I'll take that to mean 16, then ... from the menu select Settings, then click on Security & Privacy. I'm on my tablet right now and can't check the exact wording in the desktop version, but there should be a button that says something like Manage Logins.

  • Originally posted by sgunhouse:

    I'll take that to mean 16, then ... from the menu select Settings, then click on Security & Privacy. I'm on my tablet right now and can't check the exact wording in the desktop version, but there should be a button that says something like Manage Logins.

    "Managed Saved Passwords"... but I'm sure he got the general idea 😉

  • Originally posted by sgunhouse:

    I'll take that to mean 16, then ... from the menu select Settings, then click on Security & Privacy. I'm on my tablet right now and can't check the exact wording in the desktop version, but there should be a button that says something like Manage Logins.

    i did just that but it keeps telling me "You have no saved passwords. Learn more". and I don't, because it doesn't save the actual passwords for some reason. but the login info (email, username, etc) are still there and I can't delete them! nor can I make the browser remember the passwords that go with it, even though it offers me to save them every time i execute a login!

  • Sounds like the website is using cookies to remember you, but wants you to confirm who you are by filling in the password ...

  • Originally posted by sgunhouse:

    Sounds like the website is using cookies to remember you, but wants you to confirm who you are by filling in the password ...

    it's like this with all websites..gmail, tumblr, everything

  • Must be 17 then (Opera Next). There is an option in opera:flags to enable auto fill, where you can then supply your address(es) and Opera will suggest them whenever it encounters an appropriately named form field. But I'd think you'd remember if you had gone through all the trouble to turn it on and fill in all that data ...

  • Got the same thing. Opera 16.0.1196.80, Win 7 x64. When I switch off the "Enable auto-filling of forms on webpages" flag in "Settings/Privacy & security" the browser stops to autofill all login information at all, but actually it doesn't solve the problem basically. I can't manage to find from where that data could be cleaned, 'cause the "Clear browsing data" button can't deal with that.

  • Settings > Security and Privacy > Passwords > Manage Saved Passwords? Or Autofill > Manage Autofill settings?

  • Originally posted by riabradbury:

    even when I delete "all private data", I can only disable the autofill, but once I enable it I can't delete old logins I don't need. this is incredibly frustrating and I'd be happy to hear any suggestions

    I have the same thing as topic starter.

  • Well. Figured out. Delete "Web Data" file at your_disk\Opera\profile\data\ (I have a standalone installation) and all autofill info is killed. Current version is 18.0.1284.49.

  • How would I go about doing this on a Mac? I'm really disappointed that clearing autofill information is not included when you delete "Delete Private Data"...

  • thanks. deleting the web data file helped me out, but I agree that Opera should fix this and enable deleting Autofill data by using "Clear private data..."

    On a Mac you can find your profile data path via Opera -> About Opera. in my case it was /Users/username/Library/Application Support/com.operasoftware.Opera

    (current version 19.0.1326.63, Mac OS X 10.9.1)

    HTH

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.