Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Using --disable-update not working

  • I have installed an old version of Opera from before Flash was disabled. I disconnected the internet before installing so it couldn't update during installation and am trying to disable automatic updates.

    The directions I found say to add [space]--disable-update after the target path.

    I've tried this with the desktop icon and the taskbar icon. When I click, I get a popup asking what program I want to use to open the file. I have to tell it to use Opera. That does work, but the first thing it does is download a file. The flash game I want to play? Doesn't work.

    I noticed the instructions show the target path in quotations with [space]--disable-update after the closing quotation. That's how I typed it. Windows moves --disable-update inside the quotations. I don't know if that has anything to do with my problem or how to keep Windows from changing it.

    Any advice would be appreciated. My machine runs Windows 7.

  • In the shortcut dialog, there is one line for the program file and a separate line for parameters. You need to have --disable-update in the area for parameters, not in the file area.

  • Thank you for your help.

    The Shortcut tab has four editable fields: Start In, Target, Shortcut Key, and Comment.

    The "Target" field ends with: ...\Programs\Opera\launcher.exe.
    I have tried with and without quotations around the path.
    This does allow me to add "--disable-update" but I get an error where I have to say which program to use to open the file. Also it does update.

    The "Start In" field ends with ...\Local\Programs\Opera.
    I have tried with and without quotation marks around the path. It always gives this error message:

    The folder '"...\Local\Programs\Opera" --disable-update' specified in the Start In box is not valid. Make sure that the folder exists and that the path is correct.

    Deleting --disable-update gets rid of this error.

    "Shortcut Key" will not let me add --disable-update.
    "Comment" field allowed me to type --disable-update, but the game still didn't work.

    Thanks again!

  • @rsn6348 The Target field would be the place to use the parameter, but I guess it never worked in Opera.

  • OPERA_AUTOUPDATE_DISABLED

    In the version folder in Opera's program files folder, rename/delete opera_autoupdate.exe. Then, it won't be able to update. You won't need the --disable-update command-line switch then.

    You can also add the OPERA_AUTOUPDATE_DISABLED environment variable to the system (or just your user) as describe at https://superuser.com/a/908364/6488. That's supposed to stop any Opera from updating.

    Further, disable Opera's autoupdate tasks in the Windows task scheduler. See https://superuser.com/a/1169792/6488.

    Further, you can block the autoupdate server in Windows. See https://superuser.com/a/1172541/6488.

    Renaming opera_autoupdate.exe is the only one that you should have to do though.