Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

let us turn off that flash announcement popup

  • @leocg I don't know if you are running the beta or developer version of Opera, I am on 73.0.3856.329 which is up to date, and I get this popup multiple times a day:

    Flash-Player-No-Longer-Supported.jpg

    So stop replying with wrong information.

    @sgunhouse the message is definitely from Opera, windows is not putting up any messages about flash. If I had one of the plugins installed I would have got this message:

    flash-uninstall

  • @gizmogadget I use Opera Developer more often but I also have Opera Stable and I don't remember have seen that message.
    I will try checking again later.

  • I second that request. It's actually a bug in Opera as the problem is the flash plugin will always revert to "Ask first" in the settings, even if you disable it (change from "Ask first" to "Block sites from running flash"). It will be disabled until you restart opera after which it will be enabled (Ask first) again. In Opera GX there is no such problem (it stays disabled for good).

  • @macak Thankyou for agreeing with me (someone finally!)
    However your method only works if you have the plugin installed which I do not. By the way it is 23rd Jan 9am and I have already seen seen that message 3 times. Surely it is only a few lines of code to change, not as complex as a bugfix, so just do it.

  • This post is deleted!
  • @gizmogadget Actually I might have been wrong.

    In Opera GX, flash is still on "Ask first" and I'm not having the popup. In normal Opera I still get the pop-up. Btw I don't have flash plugin, but there is a flash setting in the settings menu when u go to settings -> site setting -> flash. I thought it has to be turned off for good for the pop-up to stop appearing, but looks like it's not connected to that. But it's still a bug nevertheless.

  • @gizmogadget I opened a bug report on this problem just after the first of the year so the developers should be aware of the issue. In my search for a solution to this annoyance, I have learned that this only occurs when VPN is enabled in settings. I turned that off, restarted Opera and the message did not display. At least I now know why this message is displaying when there are no traces of Flash left on my system.

  • @vinbob Thanks for that insight, that would explain why the frequency of the message being displayed is higher sometimes than others, as I use the VPN on and off about 50/50 throughout the day.
    Update: I ran opera 5 times with VPN turned on and got the message every time (I loaded some websites to make it as normal as possible). With VPN turned off there was no message. So is the problem within Opera itself, or something at the VPN servers?

  • I too can confirm that it happens only when VPN is turned on (i basically never turn it off). Great find and thx for reporting!

  • Opera finally updated itself (seemed a while since the last one) and jumped up a version to 74.0.3911.75

    I tested it to see if I could trigger the flash message (VPN on / off) it did not appear. I also looked through the settings and could not see any mention of flash in there.

    Hopefully that is the end of the annoyance.