Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • I want to prevent certain specific URLs from being predicted when I type something in the address bar. When i uncheck the option to use opera's prediction service in the settings, it still predicts the URLs I've visited, and continues to predict new URLs (but only after I've visited them once). So far, the only way I've found to delete the saved URLs is to clear all browsing history. After doing that, the prediction service continues to save and predict all the URLs I type in the address bar, even though it's turned off.

    The prediction service is supposed to save me time and effort. Currently, when I want to visit Youtube, opera predicts "", and i have to write the whole "" instead of just "y" in order to visit the front page of Youtube. It's annoying.

    This problem might be caused by a bug, but if anyone knows anything, please help me. Thank you in advance for any answer, solution, idea or contribution.

  • It may just be predicting based on bookmarks, speed dial entries, stash, etc., once you uncheck that prediction feature. It should no longer, though, be looking at your history. Now your google account, if you're using google, also has your preference for prediction with google searches. Sign into your account, and make sure you are not showing a preference for prediction in your searches.

  • Here if i go to, let's say, and open a few pages on it like, then when i type "so" on the address bar it autocompletes with and shows the other urls related to that domain on the drop-down list.

    If i go to history and remove those entries, i don't see them on the address bar anymore.

  • Exactly. And unchecking the option to use Opera's prediction service in Settings (Alt P)/Privacy and Security should eliminate Opera's using history as a predictive feature in your searches. But I believe it will still use your bookmarks, speed dial items, stash, when you start typing in the Search field.

  • The prediction is disabled in my Opera, but -- it's annoying really -- every time when I type in a new search term or URL, on the empty URL input field, -something- slows down input considerably.

    It's so bad, I'm typing a word and then have to wait for the first letter to appear. Once two or three letters are visible, the rest is handled fluently or promptly, but really, what gives?

    I open up Opera, type in ANY one single letter, and 2 or so seconds later, it appears.

    This browser is searching through SOMEthing and it takes for frickin-ever. 😕 And yes "prediction" is disabled. Can I completely, utterly disable it somewhere? Super-disable it?

  • @jammet

    I don't think the disabling of the feature is the issue at all. No way should what you describe be happening. Maybe you're totally using up your CPU. Do you typically have a lot of tabs open. Maybe there's an issue with your system resources being borderline. Are you using wifi? have a slow internet connection?

  • Internet connection is instant, CPU cores look to be free and available for Opera to use, and this happens when I have 1 tab open, or 20, and everything inbetween.

    😞 I'm clueless what is causing this. But I remember it started when the prediction feature was introduced. Since months I'm using it this way. With patience :/. This copy of Opera has all my bookmarks imported into a bookmark bar .. if I reinstall a new Opera, they will all be lost, there is no export feature yet.

  • I'm clueless what is causing this

    Do you use any extensions? If so, try disabling them and see if it helps.

  • Yes I did try that this morning. Didn't help. Cleared the history and that did not make any difference either.

    The old Opera had another way to enter URLs ... you had to press F2 first. I wish I could do it this way, here. It's an extra keypress but still much more responsive.

  • What about testing with a new clean profile? Rename your current one so a new one will be created.

  • Or if you're only concerned about the bookmarks, save the bookmark file from the Opera profile, or copy the whole the whole profile to desktop, or on a flash drive. That way, you will have everything saved, just in case you want to reinstall more tan the bookmarks in the new installation. Then uninstall and reinstall. Your can find the location of the profile in your computer, by clicking in the Opera menu, and then clicking on About Opera.

  • I found the culprit.

    In the Opera Stable directory, there was the favourites database and journal. Those were created when I first installed Opera, after it went Turbo on me ... you know, ditched Presto for Chrome.

    When that was created, there was a really poor bookmarks import utility available that would import all my Opera bookmarks and put it INTO the favourites. It created about 2000 bookmarks and many, many folders in folders in folders in folders.

    Because I really do have a lot of bookmarks. I keep a lot of URLs handy that I sometimes do not need for years. 😉 Don't question it.

    Anyway, these gazillions of bookmarks and subfolders IN the favourites, were causing this massive slowdown.
    Now that I have all my bookmarks in the PERSONAL bar, I don't need'em down there anymore anyway.

    🙂 So problem solved. The favourites routine just can't handle that much content.

    Favourites = Quickdial