Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Shortcuts will open in any browser except Opera

  • I have used Opera for a few years now and recently got a new computer and naturally installed the browser and logged in with my sign in information. I have tons of desktop icons for sites I visit regularly and none of them open. They open with Microsoft Edge, Google Chrome and Firefox. Just not Opera.

    I am running Windows 10 version 20H2 (with all the latest updates)
    I am using the most current version of Opera
    The issue occurs with every single one of my saved icons
    This is a screen shot of a sample of the problem:
    Opera Issue.PNG
    I have created a new profile in case this one was corrupted and that did not work, I've uninstalled and reinstalled numerous times, disabled all extensions and addons, reset settings and flags to default, deleted the Opera Stable folder and let it created a new one, disabled the antivirus and removed my malware program, I set and reset the default browser from every direction, I tried recreating the shortcuts in case that was the problem but they still behave the same way. I even uninstalled all the other browsers...except Edge of course...and it made no difference. I've done every bit of troubleshooting I can find online.

    The old computer which is still functional works fine. No problem with the shortcuts. I understand that no two systems can be identical but I have all the settings the same on each machine and I am completely at a loss as to what the heck's happening.

    Any help is appreciated.

  • @JRK2020 Opera is apparently set to open the file rather than the shortcut. Windows itself should open the file, when Windows sees that the file uses HTTP or HTTPS it will then call your browser. When I'm home on my Windows machine I may be able to help you fix this.

  • @sgunhouse That makes sense. I'm not sure how to change that but it seems like it must be a default setting. The offending machine is in my office so it will be tomorrow before I can take a look at that. If you have anything else to add please let me know...

  • So, any luck?

  • Actually yes. Thanks to you! I went into the settings and the Default apps and from there to "choose default apps by file type". I change .url to "Internet Browser". It was set for Firefox and didn't actually offer Opera as an option so Internet Browser was the only choice. It worked though. All the shortcuts are opening in Opera now.

    Thanks for the assist.