Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • I was happily surfing on the Internet when I saw this

    c40f4902-0090-4dfa-8a7d-d569cf0337c2-image.png

    so I clicked it and bam! This is what came next:

    0c9e991c-e134-4b4e-b4cc-5be80e4bbf76-image.png


    Really? Is this what Opera has now become? Ads all over the place? First speed-dial then this... it looks like it'll be necessay to consider a diferent browser if this trend continues. I've been using Opera since its first version and I always told people that Opera is the browser. You're doing great in convincing me that this is no longer the case.

    How do I get rid of that 🤬 % button?

  • @john-due I completely agree, Opera is the browser I have been using for years, very happy with the different integrations and improvements they have been developing.

    But for me, things like this black friday advertising or suddenly amazon being one of your bookmarks on the home page over and over again makes me rethink if it's the browser I want to use

  • @john-due said

    How do I get rid of that % button?

    Click on the three dots on the top right of the panel and then on don't show it again

  • You, Opera, obviusly need to earn money, I get it but if earning money is done only by nagging users with ads then it might be a good idea to consider splitting Opera in two different editions, powerful 100% ad-free, nag-free, promotion-free etc browser with maybe some premium features for some monthly subscription fee like 1-2$ and an ad-sponsored edition.

    Opera is still the best browser but it takes a dangerous turn into the world of ads testing us how much can we deal with and still keep using it. I'm telling you, you're on thin ice here and pretty close to loosing your most valued users who recommend Opera to others.

  • Opera: up to date OS: both Win 8.1 and 10
    This icon just appeared in the last day or so. There is no info (tootip) when hovering over it and there is nothing associated with it in the sidebar setup. I reluctantly clicked on it and received a message saying javascript must be enabled for the app to run. I have JS disabled by default and I'm not inclined to enable it to see what this is.

    Anyone know?

    Untitled-1.jpg

  • Today Opera decided to add a "Black Friday sales" widget to the sidebar on the desktop app. I didn't ask for it to be added and, despite there being an option to "don't show again", it persists.

    It's sad to see that Opera has become adware. This long time and loyal user will be switching to a less intrusive browser.

  • @ejuttner can they do this just like so at any time? Can they deploy such code without the user updating the application? This would be a huge liability :-\ Another reason to stop using it.

    I also noticed the new player b36aeb15-0fd8-4cc4-86fb-369085d19f77-image.png icon appeared today without even restarting Opera. OK, this isn't cool anymore...

  • @john-due said

    I also noticed the new player icon appeared today without even restarting Opera. OK, this isn't cool anymore...

    It's because Opera was updated to a new version/build. But it's another discussion.

  • Recently an icon started sitting in the sidebar with no explanation, no apparent function, no tooltip on hover, and no animation on hover like the other icons. Right-click offers nothing. I have performed the usual troubleshooting. I run a clean and lean system used only for work - no gaming, I have limited trusted extensions, and nothing new (other than updates) for a year. This icon occasionally disappears only to shortly reappear and persist. It is the red circle with a red dot at the two o'clock position in this grab, positioned between the speed dial and bookmark icons. It is not - of course - the Opera logo at the top. Any help appreciated. Screenshot 2020-11-27 172100.png

  • It's a Black Friday promotion. If it appears, click on it. Then click on the 3 dots at the top of the panel (next to the x to close the panel) and choose Don't show this again.