Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Save local copy of a page: Can't access the desired location

  • I'm using Opera 72.0.3815.320 on the following operating system:
    Linux ubu4 5.4.0-53-generic #59-Ubuntu SMP Wed Oct 21 09:38:44 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
    I'm logged on as a normal, unprivileged user.

    I want to save a page as a local file. I press CTRL+S, then a dialog opens for selecting the target location. I want to save the page in a subdirectory of /usr. For selecting the directory I want, I first click on the buttoncomputer.png Now I see the content of the root directory. I doubleclick on usr, because I want to go down further in the directory tree. But instead of seeing the content of /usr, i get a message
    Error opening directory '/usr': permission denied

    I think this is not the appropriate behavior, because the protections of /usr should allow reading the directory:
    drwxr-xr-x 14 root root 4096 Apr 23 2020 usr/

    As a comparison: I have no problems doing the same thing with Firefox.

  • As a workaround, you could use ~ to go directly to your home folder.

  • Saving to the home directory works well, but doesn't solve my problem. I want to save to a location in a completely different subtree. I would have to save to $HOME and then manually move the file. My preferred workaround for the time being is Firefox.

  • On most Linux systems, /usr would be non-writable (except by root). Not certain why Opera seems to enforce that when your system is different (probably something from Chromium), but perhaps some other directory would be better.

    Note that some software thinks /usr is a file and /usr/ a directory, you could see if that is your actual problem.

  • @sgunhouse
    Well, I'm not writing anything for the save location, I'm just clicking in the GUI:
    helloworld.png
    First I click on the button with the computer symbol, then I see the content of the root directory, then I doubleclick on usr .. error message!
    But I have tried entering the full path with the filename in the input field at the top .. and I also get the same error message, although the path would lead to a writeable directory.

  • Sorry, I just realized that I get a different message in the case where I enter the full path:
    temp.png

    .. and the protection is:
    drwxrwxrwx 2 root root 4096 Nov 18 22:56 temp/