Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Address/Search bar doesn't work, won't let me enter, grays out text, etc

  • Hi

    I have same problem on win10. Just updated from 72.0.3815.186 to 72.0.3815.207 which didn't help.
    Searchbox is not working when opening new speed dial, but it does on existing tab.
    When opening new tab and entering some search term, nothing happens.

    Workaround is after opening new tab, pressing tab (on keyboard), then shift tab so that focus goes off the search box and goes back. that ''fixes it''. You have to do it on empty searchbox, if you do it when something is already typed in, it will try to open page like http://opera%20searchbox%20not%20working/

    Another thing that i noticed, when opening new speed dial tab, while opera is loading that new speed tab (there is x sign left of searcbox - stop loading tab icon), searchbox works, but as soon speed dial tab is loaded it stops working (x icon changes to round arrow - refresh icon).
    Also, searchbox works fine when I'm not connected to internet.
    At last, not sure if its connected, but I noticed that if I close Opera, it doesn closes completely. Opera window gets closed, but it's still open in task manager. So, if I want to reopen Opera, I have to close processes which is extremely annoying as much as searcbox problem.

    This is some wierd bug
    If it doesnt get solved by the end of the next week, im switching browsers.

  • 533b3da2-2a86-48d6-ae56-c26a640923b6-image.png

    When typing into the search bar on a new tab the text is grayed out and no results appear underneath.

    This can currently be fixed by clicking off when the text box is empty and clicking back on again but this is a bit of an annoying bug.


  • You can click off and on again on the search bar as a temporary fix. Hoping the devs see this soon as it's quite annoying!

  • @namero999 heck it seems sufficient to just unfocus the field (by clicking outside) and focusing it again. Also note how the font looks different before and after (before is really thin)? What a weird bug.

  • I am having the same problem with two differents computers. Windows 10 x32 and x64 with last Opera version. F5 key works to reuse the browser. I can't use the tip given by @namero999 pressing <TAB> key.

  • I open the empty tab, I input the URL, I press enter - nothing happens.
    In case I use some bookmark to load any website, and then enter the URL, it works just fine. It all started 2 days ago.
    Opera 72.0.3815.207 Windows 10 x64

    The issue is pretty similar to but killing GPU process doesn't help.

  • Yep seems like the same issue.

  • Came here to report the same issue. I'm using Opera 72.0.3815.207 and Windows 10.

  • Same issue - 73.0.3856.31 from beta. F5 and Alt-Tab works.

  • Same issue. Opera 72.0.3815.207 and Opera Dev 74.0.3862.0, started happening yesterday.
    Workaround 1: just type anything fast enough and hit enter to get your SE to load up so you can finally safely type for any amount of time both in address bar and search box.
    Workaround 2: duplicate any already open tab that works, proceed with your search.

  • @andrew84 Good point. I finally broke down kicking and screaming and bought a new computer with Win 10 last week, went from Win 7. Win 10 is constantly updating it seems. I'll have to break out my laptop with the Win 7 and see if there's issues on that.

  • Ctrl+Enter solves the problem with manually entered URL addresses (instead of Enter)

    Unfortunately the search does not work with Ctrl+Enter. Let's hope that Opera finds a solution quickly.

    Corrupted version: 72.0.3815.207

  • @Stinkerbell it's not related to OS, it's opera update that ruined it

  • I still have the same problem.
    Version is: 72.0.3815.207

  • Hi,
    I have such a werid problem. I cannot search with Google in the new tab while Google search is opened in the previous card, I mean in the basic top bar. What should I do to search in every tab freely?

  • Same problem, version 72.0.3815.207.

  • This bug was there and still is for at least 3 updates.
    Popups (to login via google) are opening like after about 3 minutes after the click even with popups allowed for the site.
    Stylus has lots of bugs too, like not opening properly or not saving or applying styles.
    They broke something very important and it shows everywhere.

  • @perk-one said in Search bar won't let me enter, grays out text randomly:

    I still have the same problem.
    Version is: 72.0.3815.207

    How I see this happen only on speed dial. When I already have an open tab and start to typing in the address bar it suggests and searches.

  • I can confirm;
    search and input work in an already opened tab.

    And with Ctrl+Enter you can call an address or open a working tab ; )