Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

'weather forecast not available' on startpage (flag)

  • @severalpeople Go to opera://flags and enable Weather on Startpage.
    After that go to Settings>Privacy and Security and uncheck Location (see picture). I had the same issue and with this i fixed it.Sem Título2.png

  • @oliveira56 no bro im not risking my security for that, any site I go to will have my location

  • The opposite to Ask is Never, if you turn it off then no one will be able to use geolocation. (Many sites will still guess your location based on your IP address, but they do either way.)

  • @sgunhouse checked and it is already on https://i.gyazo.com/22cf653fad8143902efc155e21d97aad.png still wont work

  • @severalpeople You can't even set a location? Or you already set up one but the weather tool isn't working?

  • @leocg cant set location up i get this alt text

  • same here.
    location enabled, widget enabled.
    but still "Weather forecast not available".

    This has been happening since the last 2 updates i got. Prior these 2updates, it was working.

    On "normal" Opera browser it is still working, only in GX is now not working anymore.

  • @rabid7 It is not working even on my normal browser

  • Apparently, it becomes like this when you select decline the first time the weather's dialog is shown (where you would otherwise set the location manually or select accept and let your location being handled automatically). After doing so there was somehow no way to reconfigure it.

    To resolve this limbo-like status, close down Opera via ⌘Q, open ~/Library/Application Support/com.operasoftware.Opera/Preferences in a text editor and search for weather, which leads you to:

    "weather":{"custom_location":"","enabled":true,"onboarding":false}
    

    There, change onboarding's value to true and reopen Opera, which should make the weather's dialog appear again upon clicking the widget, so you can then either choose accept or enter a location manually.

    On Windows, it should be analogous and the path is probably something like %APPDATA%\Opera Software\Opera\Preferences.

  • Not working on normal Opera after the last update

  • @perfectday please follow the above mentioned steps.
    I hope it will start working. Moreover, you can also roll
    back to the previous version.

  • @naheed Thank you for the advise, but before posting I tried to do everything mentioned here. Perhaps some preferences in MacOS preventing widget work. So yes, probably the only chance to fix is rolling back to the previous version. Thank you.

  • How to fix "Weather forecast not available" (Windows guide, i don't know if will work on MacOS, you can try)

    (Before doing, close your opera)
    Go to desktop, press Alt + R and write %appdata%
    Opera Forums 1.PNG Hit Ok
    and go to Opera Software -> Opera Stable. Scroll down, inside there should be file called Preferences.
    Opera Forums 4.PNG
    Move it to desktop, then open it using notepad.
    Opera Forums 5.PNG

    Next up open Opera. All your settings will be gone but everything will be back to normal later. Choose where you live and close Opera. Then go to folder where from we moved preferences, and there will be new file called preferences. Open it using notepad and put it aside.
    Like that:Opera Forums 6.PNG
    Then on Preferences on left side press Ctrl + F and search "onboarding"
    it should find this line (look at photo).
    Opera Forums 7.PNG
    Copy this line that i highlighted. Now on the Preferences that was put aside Ctrl + F and find "onboarding", it will lead you to same line. Now before that line i highlighted press Enter, so you can have something like that (look at picture)
    Opera Forums 8.PNG
    Now delete that line i highlighted and paste the line that we copied on the place of deleted one.
    So it will look like that: Opera Forums 9.PNG
    Now close and save changes to right and left Preferences, then move the Preferences from desktop to Opera Stable folder and choose replace files. Then open Opera and Boom Opera Forums 10.PNG
    😃

  • @bsod Edit: press Windows button + R instead of alt