Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved] no sign-in button visible in Opera, as is in Chrome

  • Our town newspaper (San Antonio TX) has a free summary of the news at https://www.mysanantonio.com/news/local/

    Does anyone see a Sign-In button in the upper right corner of the home page? I don't.

    But I do using Chrome.


    The newspaper has another website, more of a copy of the printed paper, at www.expressnews.com

    In the upper right corner I can see (in Opera) a Sign-In button. But when I go to click on it, the letters turn red and the mouse cursor turns into a vertical thin bar, like a capital I. Clicking doesn't do anything.

    I haven't tried, but I'd bet it would work in Chrome.

    One of my Opera settings must be wrong, but I can't see which one.

    All help appreciated. Thanks.

  • Strangely, there is no button in Firefox either. Probably something to do with the ad blocker then ... yeah, if I turn off the tracker blocker specifically the sign in button appears.

    What is called the I-beam cursor is supposed to show when there is a text form there. If you look closely on your first URL you'll see an I-beam cursor when the mouse is where your sign in button should be, but with the tracker-blocking off the cursor stays as a hand.

  • Curiously, there's no sign-in button in "regular" Vivaldi either, but one does appear in a Vivaldi "private" window. The differences in that Vivaldi installation are that the private window lacks two tracker/ad blocker extensions (Ghostery and NoScript) that are present in the regular window. Otherwise, both types of windows are set to allow Vivaldi's ad-blocking. The implication seems to be that there's a tracker or ad callout that is being blocked natively in Opera and in at least one of the Vivaldi privacy extensions that isn't being blocked in regular Vivaldi.

  • You can see it using Opera + ublock origin. There's no problem to login when you click it.

  • @diezi
    I installed ublock origin, went to both websites, no help.

    Refreshed the pages (Ctrl - F5), still no help.

    A few hours ago I cleared the cache on Opera. That didn't help either.

    And adblocking built in to Opera has always been turned off. (To end the legitimate requests by websites to turn it off.)

  • @stevek2 These is my screen:
    2020-09-02_175150.jpg

    Maybe it is some configuration I am using or the filter list? I cannot help you more with it. The ublockOrigin Reddit community is very active, probably they could help you with some configuration.

  • This is the OP, and I think I've solved the riddle.

    Turning off "Block trackers" in Settings > Privacy protection seems to have fixed this problem.

    It also allowed a password to be saved on my public library's website.

    Not clear to me what trackers has to do with it exactly, but there we have it.

Log in to reply