Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • Whenever i watch a video (especially good noticible in dark ones) the video gets "Pale" like there is no contrast. Black looks dark grey etc.. However when i switch tabs or scroll down, the video has normal contrast again but when i go back to the tab or scroll up its getting too bright again. F.e i watch a video on youtube and its too bright and then i scroll down until its not visible anymore, scroll up again and its normal looking (black is black) but its just for a second. When i pause the video in that second it stays good. Example too bright Example good looking

  • @leocg I did everything on the top from the link you sent because i use Opera GX and i tried reproduce it on normal Opera with a new and clean install with standard settings (It happended there too). I use Windows 10 and Opera GX even though its on the normal browser as well (ver. LVL 2 or 68.0.3618.197)

  • @sebo74 Everything on the instructions are valid for GX too, that is basically Opera with a different UI and some different features.

    Any examples of videos where the problem happens?

  • @leocg It happens on every video on youtube and even streams on twitch. Its just that dark scenes are effected more because all the black areas become dark grey-ish

  • @sebo74
    Does it happen with Chrome or new Edge? (They share same rendering engine, although video part can be a bit different.) What kind of graphic card your PC has got?

  • @donq It happens on chrome and edge too. Ive got an rx 5700 xt gpu. It doesnt appear on firefox though. So as u mentioned its gotta be the rendering engine. any advice on how to change it?

  • @sebo74
    In video adapter control panel, have you set some strange video 'enhancement' mode or something? Sorry I have no experience with newer graphic cards (I do not play games), but even for my integrated graphics I can set various effects for video playback.
    You can always update video driver - but usually this doesn't help.
    You may check with Opera developer branch (you can install it side-by-side with main browser) - if there are no ill effects, then it is already fixed 🙂

    BTW, if this problem is shared with Chrome, you may ask on Chrome/Chromium forums too - there are more Chrome users and possible someone knows exact solution.

  • @donq wow thank you. it was in my gpu settings indeed i wonder how i didnt think of that. Thanks so much 🙂