Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Extension upgrade requires additional permissions...

  • @nickyt Button on the right of message, "go to the extension". Simple.

  • @mrup Right of message, button "go to the extension". It's not that difficult.

  • @mateuszr42 No is not like that. When clicking on "go to extension", in the extension box there is some specific slider, with that is very simple to accept the new permission for the extension.
    You don't need developer mode, this is for other stuff, and the download you've done could not be appropriate for you.
    That switch, I've used it thousand of times, even there are extension that tends to ask permission repeatedly. Now I don't remember the exact text of the switch, but it is very simple, /if you read it/ with some slowdown and calm ^_^ don't be in a hurry and try to slowly read every line by every switch. You will surely see it.

  • @deggtsk Button on the right of message, "go to the extension". Simple.

  • @vlads111 Button on the right of message, "go to the extension".
    You have /not/ to perform an upgrade, but instead, to /accept the permission change/, so to let the browser to update the extension. In the box read every "switch" description, you will find it.

  • @draker Button on the right of message, "go to the extension". Simple.

  • @perdigao1 If you have unknown extension, you better remove it!

  • @xxkernljrxx update your browser to latest version. Seems they have fixed the permission problems. You better do that before ajll.
    Any way, right of message there's "go to the extension" button. In the first ext box that opens, you should enable permissions for the extension to access the webpages, or, give to the extension additional permissions if required.

  • I was receiving this error and was able to correct it by simply modifying the shortcut and specifying "Run as Administrator". After starting the application the message was gone. I then reverted back to normal (not run as administrator). It has been working fine since. It appears that there is an extension somewhere that requires admin rights in order to initialize.

  • @albertop hey so i was reading through your message because i am also having this issue with Opera GX and i couldnt find where i could enable/add permissions to the extension? so do you know where that is I am using Opera GX version 76.0.4017.208 LVL 2. so if you could just lead me to where specifically i can enable these permissions because i have gone through every option here and cannot find it?

    0868ec30-3230-4578-b4c0-6879f54bb49a-image.png

  • @shampoo Hi, if I remember well, you need to start the opera with the flag --show-component-extension-options.

    If you have a shortcut on the desktop, it is probably better to create a copy of it, then right-click and choose properties, choose tab called 'shortcut', and in the field target add to the end the flag. I think this is the way to get it working and remove the annoying extension.

    Good luck

  • @albertop there's no "switch" to read