Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Can't access my router with VPN disabled

  • Hello. New to Opera. Still getting it set up - and have just found that I can't seem to access my router. Get halted on the "Your connection is not private" error page. The browser typical "Back to safety" option is there - but no way to continue on to the router regardless of the warning. Grrrrrrr! I need access to my router yesterday! Can any kind soul tell me how I can make opera allow me to do this simple thing?

  • @gordon
    VPN disabled or enabled? I haven't used VPN and haven't had any problems like you described.
    Actually I have not seen "Your connection is not private" screens either 😞 Does it include some link/text like "More information"? Sometimes under such link (if clicked) opens another link - to continue and direct to requested address.

  • @donq

    Thank you for your reply.

    VPN disabled. No, only 2 options and neither allows me to continue to my router. "Back to saftey" and "Help me understand". Very odd. Every other browser I have used in the past has included the option to continue anyway despite the security warning - but not here with Opera. In the end I installed the Brave browser and accessed my router no problem via that. Such a pity as I was really loving the Opera browsing experience up to that point (particularly Speed Dial with an animated background :).

    There must be a way though - surely?

  • @gordon Help me understand sometimes gives you a way to continue, did you check?

  • @leocg

    Had checked for that several times over, lol. Even took a snapshot to show you - but can't see how to upload an image from my laptop (wanted a url). But, went back to check one last time - and found the link you speak of. Was just a ghost of very small print that was almost entirely invisible due to me running the blue light filtering software "Iris" (love it). I turned the brightness up a tad and there it was clearly visible. Checked it and it works fine.

    So, problem solved thanks to you - and you sticking with it 🙂 Much appreciated. And I hope the Universe awards (both of) you a substantial handful of good karma points for it 🙂

    I'm back in love with Opera (sorry Brave).

    Onwards and upwards!

  • @gordon Use the button that looks like a image in portrait mode, the last one in the toolbar, to upload images.

  • @leocg

    Ah. Thank you.

    Opera - Router Block.png

    I just went back to try and give you a pic with the "understand" part opened and - drum roll - then problem no longer happens, lol. I guess Opera has 'learned' as is just took me straight into my router homepage.

    Thanks for sorting me out with the image thing 🙂

Log in to reply