Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Self emails don't show in Received or Unread folders

  • This is a problem I've come across. I tried to send an email to myself to check the network wasn't down. This email didn't show in my in folders, only in Sent. Is there a setting so that I can see emails I send to myself as having actually arrived? My webmail account does this fine.

  • For the Received and Unread views, click the "settings for this view" button on the message list toolbar and uncheck "threaded" to see if the message shows. If it does, then you're running into a bug where if the first message in a thread is sent by you, it's hidden. The thread in your case consist of only one email.

    If that doesn't work, set "show sent" for the Received and Unread views.

  • @burnout426 Sorry I don't see a message list toolbar.

  • By "Message list toolbar" he means the toolbar immediately above the list of messages. It should the the second-from-right button, and when you hover the pointer over it the tooltip will say "Settings for this view". Presuming you're talking about Opera Mail or else mail in Opera 12 - in older versions it was organized differently.

  • @sgunhouse Ok tried all that ('Show sent'...) but all I get are 'To my email@...." messages, I don't get them coming back as from me..... My webmail on Firefox does this with no problems. It's as if Opera decides for me that an email sent to myself must only be shown as going out, not coming back.

  • As I have no trouble seeing messages I send to mailing lists, that is not something Opera does. If you have disabled "show sent" and still see the messages, obviously you see the received ones.

Log in to reply