Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • am loving opera, however, when i open gmail in opera and click a link it automatically opens in chrome rather than opera.

    where can i change this behaviour so that links open in opera?

    tia

  • @ushere What kind of link? Does it happen only on Gmail?

  • @leocg thanks for the quick reply, much appreciated...

    as an example, take this reply. i opened gmail within opera, which works as expected, but on clicking the 'view post' it's opened in chrome. this action applies to any links contained within an email opened in gmail in opera.

    i have tried to find some info about whether i need to change a setting. within either gmail or opera. but have drawn a blank?

    all links within opera work as expected.

    thanks for your time and advice

  • @ushere Maybe some setting on Gmail?

    Is Opera set as your default browser?

  • opera is default...

    i can right click a link and force it to open in a new opera tab, but simply clicking it opens in chrome.

    i've checked gmail settings but there's nowhere to define how links are opened?

    of course, this isn't the end of the world (no matter what might be going on in it at the moment 😢 ), but it's one of those irritating bees you get under your bonnet 😉

  • @ushere Did you already try with extensions disabled and with a clean Opera profile as in the instructions?

  • hj leocg, and thank you for your time and trouble, most appreciated.

    yep, disabled all exten. and tried clean profile - same problem.

    i think i'm simply going to remind myself to right click links till it becomes second nature 😉

    no point wasting further brain cells - not that i have that many left anyway...

    thanks again

  • @ushere Try check Windows settings and make sure Opera is the default handle for http/s protocols and htm/l extensions.

    By the way, I've tried a few links in Gmail messages and they all opened in Opera.

  • @leocg now that's interesting...

    web browser is set to opera in windows settings, but for some reason neither http or htm was pointing to opera. chnaged both to opera and bingo, we're in business.

    many thanks for your time and patience. if you're ever in the upper hunter in australia, let me know and i'll buy you a cold one 😉

    stay well and healthy