Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera changing UI language

  • Hello.
    I live in Russia. But I still prefer to consume content and use my products in Englisn.
    I run Windows, and the system locale is set to English. I set Opera's locale to English. I even delete Russian language from the list of suggested languages.

    It's no use. Every time I log in to my PC in the morning - Opera is helpfully switched to Russian.
    Because, clearly, it must think that I am stupid, and I didn't mean to switch it to English the day before, and because my region is Russia - then I clearly want to see Russian.

    Thank You.

    Now, how do I turn this annoying feature off and make it so my browser is in English and stays in English?

  • Leave Russian there but tell it to use English?

  • That's what I tried to do as well. Removing Russian was simply an act of desperation.
    It still switches to Russian every time. Sometimes, rarely, it takes 2 days for it to mess itself up, but it inevitably does.

    Just to prevent any other obvious answers, what I'm doing is:

    Opera -> Settings -> Languages -> 3 dots next to "English (US) entry" -> Display opera in that language.

    It prompts opera restart, and it does work. For a day, or at most a couple of days. Then it turns back to Russian on its own.
    So this isn't a disk write problem, because obviously sometimes the settings presist after PC reboot, and sometimes they don't. Something in Opera actively re-writes my settings to set up Russial locale over and over.

    What I suspect happens is that Opera downloads some updates, detects that I'm in Russia, and "fixes" my annoying English problem for me - Yay!

  • @aisaaax Go onto Opera, and type this into your search bar
    opera://settings/adBlockerLists?search=languages
    or you could also just navigate to the "Block Ads - Manage lists" section on Opera settings. Then disable Russian (RU adlist). Once you do that it should not go back to Russian anymore. If this continues to happen to you for other languages as well, try this same method. This has worked for me for the past few days but I don't know how long it will be like this for me.

Log in to reply