Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera Video pop out freezes

  • @oelmensch New video pop-out or the old one?

  • @leocg It still freezes, the video on the main Tab shows normal, the one in the pop out does not.

    If you lower the quality, it might work for some time, but eventually it will freeze again

  • It looks like there is a issue with the old pop-up. I change back to the new pop up and everything is fixed :
    URL -> "opera://flags" -> Use surface layers in Video Pop-out -> click "enable" -> Relaunch

  • When I enable the flag a new problem occurs: After pressing the button to activate Picture-in-Picture mode a small black Window pops up in the right corner of my screen and the main Tab turns black as well. The video continues but just the sound. By the way I'm using Opera version 67.0.3575.79.

  • Here are my problems summed up.
    Since I've updated Opera to version 67.0.3575.53 (meanwhile I've updated to version 67.0.3575.79 but the problems are the same) the Pop-Out player doesn't work anymore. That means when the flag "Use surface layers in Video Pop-out" is disabled (like it has to be in the older versions) and I press the button to pop out the window the old window pops up but frezzes shortly after that, the main window (e.g. Youtube player) works properly. photo5420583009607855599.jpg This problem can be solved by lowering the quality of the video but that is not a nice solution.
    By disabling hardware acceleration the pop out player just shows a black window.

    When the flag ist set on Default or Enabeld (like @Henry97 said it should be) and I press the button to pop out the window a black window pops out in the right corner of the screen and the main window turns black as well but the video contiues (I think so because there is still sound).photo5418106668903935725.jpg
    Dis-/enabling harware acceleration doesn't change anything.

    I hope you have enough information to solve the problem:)

  • Hi @oelmensch, you can try to run the Opera with one of the following switches (one at the time):
    "\path\to\launcher.exe" --disable-gpu-compositing ,
    or --disable-direct-composition-layers, or --disable-direct-composition, and see if any of them helps.

    You can also perform the below steps:
    1. Open the Opera, make a note (copy it) of the path to your Opera's profile under opera:about > Paths > Profile, and close the Opera,
    2. Navigate to that path, search for the file "Local State" (make a copy of it, in case something goes wrong you can revert it from the copy), open the file in your text editor, search for "enable-surfaces-for-videos":.. , and if you find it, remove the whole section (together with the value), save the changes, and close the file,
    3. Relaunch the Opera, and see if this changes anything.

  • @l33t4opera it finally works thanks a lot ❤ I use this feature a lot so when it stopped working it felt like living in the Stone Age again 🙂

  • @oelmensch You're welcome ;-) Could you tell, which of the above helped in your case, or something else? So the other users can try it as well to fix the issue for them.

  • @l33t4opera I have this issue as well, and I'm unsure how to run using switches. I tried the doing the local state file edit, but it didn't work.

  • @turndown4wat Example for switches..
    right click Opera Shortcut - click Properties - on the Shortcut tab, in The Target feild..

    Example

    "C:\Browsers\Opera\launcher.exe" --disable-gpu-compositing
    f2b1772b-e671-431a-8622-6e56a6e7c002-image.png

    after the launcher.exe" tap the spacebar for a space then --disable-gpu-compositing

    Hit Apply and ok it..

    try each switch in the Target feild one at a time..

    switch 1 : --disable-gpu-compositing

    switch 2 : --disable-direct-compositionlayers

    switch 3 : --disable-direct-composition

    hope ya get trouble solved soon..

    if nothng helps try this also

    try this -
    check this flag called -

    Use surface layers in Video Pop-out and make sure it it is Not (Disabled)

    if it is - set the flag to (Default)

    and relaunch browser then try Video pop out again..

    if that default setting does not work - set it to Enable

    for me default or enable works for me..

    Note - it will be the new Video Pop-out

    Btw @oelmensch glad ya got things going !..

  • I just opened Opera via the console. I searched for the path where the .exe file is located then I entered the command path\to\launcher.exe --disable-gpu-compositing
    Atfer that everything worked and I even got the old pop out back

  • @nvmjustagirl The first reverted it to old PiP but was just black.

    the second one worked eventually, and seems pretty stable as of now so that's the one that worked for me. I say eventually cause at first it was just a black screen as well, but after retesting all of them it suddenly showed the video, although it would freeze after 3 seconds. But closing it (the PiP not the browser) and opening it a few times made it work. This happens anytime something loads (a website or a video, even bringing up this reply box froze it) but honestly it's a small price to pay for a working PiP.

    The third looked to work but then I clicked on a different video and my entire Opera froze and i had to force it close. When I opened it back up, the PiP would freeze immediately.

    Thanks for your help

  • @oelmensch said in Opera Video pop out freezes:

    I just opened Opera via the console. I searched for the path where the .exe file is located then I entered the command path\to\launcher.exe --disable-gpu-compositing
    Atfer that everything worked and I even got the old pop out back

    WoW ya got the old pop out back ? ! looks like ya have stumbled on to sumthing..

    not desputng what ya said but i think version 66.0.3515.115 was last version for the old style pip was working..

    also in earlier post ya said ya was use 'n Opera version 67.0.3575.79.. the old style does not work in that version.. only the new pip does..

    i wish @l33t4opera could test this..

    if old style pip works in newer versions of Opera, please do tell and show how !..
    *thankyou in advance..

    @turndown4wat thankyou but @l33t4opera deserves all the credit.. just glad ya got things work 'n..

  • @turndown4wat this may help..

    disabling windows transparency seems to stop sum laggs & delays

    Right Click on the desktop - Personalize - Window color - Uncheck the box or (slide the switch to left latest win 10) "Enable transparency" - Save Changes..

  • @nvmjustagirl
    Well it kinda works. The video still freezes sometimes but just once or twice every video. So it might be not the best solution but I'm ok with this

  • Hi @oelmensch, I'm glad to know the mentioned switch helped in your case ;-)
    In the future, when the similar issue occurs, you can try to update your graphics card driver, or check if launching the Opera with the switch --disable-gpu-driver-bug-workarounds (instead of the previous one) helps in that cases.

  • @turndown4wat i doubled check that 2nd switch i had typed it wrong (--disable-direct-compositionlayers)

    sowwies bout the typo turndown4wat

    so i am gunna copy/paste it to correct my mistake..

    switch 2 --disable-direct-composition-layers

    retry the switch 2 but to me i dont think ya need it not unless ya copied it right from l33t4opera post..

    ya might see if this flag helps copy/paste this url -

    chrome://flags/#ignore-gpu-blacklist
    Enable the flag to make sure your gpu is not blacklisted..

    the fag name is called - Override software rendering list

  • @nvmjustagirl said in Opera Video pop out freezes:

    @turndown4wat i doubled check that 2nd switch i had typed it wrong (--disable-direct-compositionlayers)

    sowwies bout the typo turndown4wat

    so i am gunna copy/paste it to correct my mistake..

    switch 2 --disable-direct-composition-layers

    retry the switch 2 but to me i dont think ya need it not unless ya copied it right from l33t4opera post..

    ya might see if this flag helps copy/paste this url -

    chrome://flags/#ignore-gpu-blacklist
    Enable the flag to make sure your gpu is not blacklisted..

    the fag name is called - Override software rendering list

    I tried enabled flag -Override Software Rendering List- and also disable on -Use surface layers in Video Pop-out-
    and the pop-up video is working! both on youtube and other streaming websites.

    I hope it will stay working for while

  • @aibenq thanks now it works fine.
    There is one small issue though. When I'm watching a video at a diffenrent speed (2x the normal speed) the window freezes again. Does anyone has the same issue?

Log in to reply