Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Disable bookmark preloading?

  • I have some bookmarks that trigger test events on software I write. Whenever I load one of them in a bookmark folder, the others are also loaded. Is there a way I can turn this off?

    Using 65.0.3467.62 on Windows 10.

    Thanks!

  • @mrsmith said in Disable bookmark preloading?:

    Whenever I load one of them in a bookmark folder, the others are also loaded.

    I'm not sure what you mean. Could you explain in detail?

  • Guess would be he's opening the entire folder at once via Open all, but only wants the one in the foreground to load. But it is a guess, we'll have to see ...

  • @sgunhouse I do use the open all at once for other bookmark areas so I'm familiar with how that works but I'm not using the "Open all in new window" command in this case so I don't think that applies here. I'll explain in more detail...

    I have one subfolder of bookmarks that contains four entries in it. Each of the four bookmarks in there browses to a link that then triggers an email to be sent by the server that you browse to. Theoretically, when you click on one of the bookmarks, only that link should be followed and, therefore, only one email should be sent. That's how it worked when I was in chrome (where I imported these and the rest of my bookmarks from). In opera, if I click on one bookmark, I get all four emails as if I had clicked on all four bookmarks one by one.

    I figured maybe opera was loading the others in case I happened to click on one of them next. I just can't figure it out. It's starting to get a bit annoying and it's the only issue I have with this great browser. Very confused over here...

  • Thanks for the clarification. Maybe it's something to do with favicon fetching where Opera checks for updates on the icons for all bookmarks. Can you check the requests received by the server to see if that's the case?

    Also, goto the URL opera://settings/privacy and disable "Use a prediction service to load pages more quickly" to see if it helps. Restart Opera after disabling it just for good measure.

  • @burnout426 Thanks for the hints. I do see that setting as disabled already. I did go the apache logs and there is one request for the favicon then there are the other requests that I wish hadn't happened and they all come from my wan IP so it's me for sure.

  • @mrsmith Just so we're all on the same page, what way are you launching the bookmark? Are you going to "Menu -> Bookmarks -> Other Bookmarks -> the folder" and clicking on the bookmark or are you clicking on the bookmark via the bookmarks bar or are you clicking on the bookmark via the bookmarks panel in the sidebar or are you going to the opera://bookmarks page and clicking on the bookmark or is the bookmark a speed dial entry and you're clicking on it via the start page?

    Does it make a difference which way you do it?

  • I tested this myself with Wireshark in Opera 65.0.3467.78 64-bit with a fresh profile and empty cache on Windows 10 OS Version 1909 (Build 18363.535).

    I can't confirm the issue. When clicking on a bookmark in a bookmark folder to open the bookmarked page, connections are made only for the bookmark's site. Connections for other bookmarks are not made. I tried on the opera://bookmarks page and on the bookmarks panel in the sidebar.

  • @burnout426 Interestingly, the behavior seems to have stopped. I've been trying to duplicate the issue using the same steps as before (going to the bookmark toolbar, clicking on the folder in question, selecting an option that flys out a submenu to the right, selecting one more option that flys out the last selection to pick from to the right and clicking on only one of those items). Currently, only the one on that sub-sub menu list I click on is loaded instead of all of them.

Log in to reply