Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Changing a password in Opera Settings Password Manager?

  • I cannot get Opera to ask for me to update facebook password EVER!!! AND It appears there is no way to change the password in settings....AM I WRONG!?!?

  • Juse type in the new password on the site, and Opera will ask if you want to replace the old password with it. It isn't that hard.

  • @sgunhouse
    That doesn't work when I try it on Amazon passwords. Opera had an old password, continued to use it even if I replaced it and never asked to use the new one. I deleted the Amazon entry, then accessed my account (hoping to created a new password entry) but again I'm never asked if I want to save the pw.

  • In addition to deleting the amazon.com password entry, goto opera://settings/siteData and remove all amazon.com cookies and site data. Restart Opera and try again.

    If that doesn't work, download the Opera installer, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "standalone installation", uncheck "import data from default browser" and install. In that Opera, do not example Opera Sync or install any extensions.

    In that test Opera, goto amazon.com and log in to see if you can get Opera to ask to save your password. If so, choose to save it. Then, goto the URL opera://settings/passwords in Opera and click the 3 dots to export your passwords. There will be only one entry in the file and that'll be for amazon.

    In your normal Opera, goto opera://flags/#PasswordImport and enable password importing. Then, restart Opera. Then, goto opera:/settings/passwords, click the 3 dots again and choose to import your passwor from the file.

    You shouldn't have to do things that way, but you can try it. You can then delete that standalone installation.

    Another thing you can do in your normal Opera is to enable opera://flags/#enable-autofill-ignore-autocomplete-off and try logging into amazon.com again. I don't see an autcomplete=off attribute on the password element for the login form, but you can try anyway if you want.

Log in to reply