Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Screen won't turn-off or allow screen saver to activate with Opera Window open

  • For whatever reason in the latest updates that Opera pushed out my screen will no longer turn off and/or it will not allow the screen saver to activate if I leave the Opera window open on the screen.

    It will work if I minimize the opera window or close it completely.

    I've tried uninstalling and reinstalling and it still causes the problem. This doesn't happen with Chrome so it's definitely something with Operas latest updates pushed out recently.

    Can someone at Opera please fix this problem, it's really annoying. Thank you.

  • The problem happens with a clean new Opera profile?

    I don't use a screen saver but the monitor goes down without problems here even with Opera opened.

  • I've uninstalled and reinstalled so I guess that would be a clean opera profile? It's weird.

  • It depends on if you checked the option to remove your data or not.

  • Oh I see. Yes, data deleted. Also ran CCLeaner afterward. Rebooted, reinstalled, rebooted (for good measure) and then attempted to duplicate the problem again.

    Still happens. Doesn't happen with Chrome. Doesn't happen if the Opera window is left open but minimized. Only when it's the active window on the screen.

    I am signed into my browser though so my data is synced with their servers. Perhaps that is a problem? Although I'm not sure why it would be because I have been using this setup since I started using Opera a few years back and haven't encountered this issue.

    Only since the last 3 or so updates they pushed down has this been a problem.

  • There are pages opened in Opera when the problem happens?

  • Yes, at first I thought it was YouTube that I would leave open on Pause so I stopped that. Then I thought it was Facebook so I closed that. Then I picked just a random page like Google Search results to leave open to be sure it wasn't the page code specifically causing it. Seems it doesn't matter.

  • It happens to me too, and happened with the previous version too (the one with the slow speed dial). It doesn't happen all the time, so I guess it must be after I do something in the browser, regardless of the resulting active page. It even happens in Speed Dial or with Opera minimized.

    I did some attempts, like using Youtube full screen and then closing the tab, but that didn't cause the problem. It just happened again minutes ago while Opera was in https://www.facebook.com/messages. I'll try to do some further testing to see if I can find exactly how to reproduce it.

    @LunchBoxSteve said in Screen won't turn-off or allow screen saver to activate with Opera Window open:

    Yes, at first I thought it was YouTube that I would leave open on Pause so I stopped that. Then I thought it was Facebook so I closed that. Then I picked just a random page like Google Search results to leave open to be sure it wasn't the page code specifically causing it. Seems it doesn't matter.

    Steve, I guess once Opera is in "avoid screensaver" mode, it doesn't matter the active page. You will have to close it and reopen it to try to find what site produces this.

  • It's happening to me to. Really annoying. I may have to write an AutoHotKey script to minimize the window after some amount of inactivity.

  • If anyone else find their way here, here is an AutoHotKey script that will minimize Opera and turn off the monitor. During development of the script, I bound a key to just turn off the monitor. With Opera not-minimized, when I would hit the key, the monitor would turn off, and then turn back on in less than a second. With Opera minimized, it would turn off and stay off.

    Note that if you have sound playing through the browser when this script triggers, the sound will continue. That's a good thing since many people will be using the browser for music, or other background noise.

    Just put this at the top of your bind-key script. Don't bind it to any key. It will not block the script from reading the rest of your keys.

    Loop {
      if (A_TimeIdle > 120000) {
        if WinExist("ahk_exe opera.exe") {
          WinMinimize
          Sleep, 500
          SendMessage 0x112, 0xF170, 2, , Program Manager
        }
      }
      Sleep, 10000
    }
    
Log in to reply