Any possibility to have a readable status bar?

  • Hi all,

    Since the address of a link does not appear inside a balloon in Opera, the status bar is indispensable to check for it and e.g. avoid counterfeited links. Then why is it grayed out and almost unreadable? This is the same with "Opera Unix Skin" and "Opera standard", and removing special effects does not help.

    Is there a theme somewhere for people who don’t value visual niceties over usability?

    Cheers,

    Alexandre

  • Although it's probably a bit too late to get into customizing Opera/Presto, you could also run it in X11 mode if GTK theme integration doesn't quite line up with your expectations. http://my.opera.com/ruario/blog/make-x11-mode-look-better

  • Thanks rilef for the reply. Restoring the toolbar to the default did not help. I don't mind about desktop environments and use IceWM which is rather barebone without particular theme.

  • Thanks Frenzie for the reply. I set opera:config#FileSelector|DialogToolkit to 4 in order to run in X11 mode but did not notice any change after restarting Opera. The status bar text is always displayed in gray on gray.

  • @rilef: Well I tried the 2 provided themes in Tools>Appearance>Themes. I don’t even know the difference between a theme and a skin. I had not found a specific forum for the Linux version and will look for it now.

    @Frenzie: changing the opera:config#FileSelector|DialogToolkit to 4 was of course unrelated to the problem at hand, but it allowed me to get rid of GTK file chooser’s irritating behaviour, which is not particular to Opera: my long list of unmounted fstab entries appears in "Places", hiding away the favourites. Now I still have to find out how to run the whole Opera in X11 mode.

    Cheers,

  • Originally posted by alxobr:

    changing the opera:config#FileSelector|DialogToolkit to 4 was of course unrelated to the problem at hand

    It's a hard-coded gray? Ugh, that's unfortunate. Still, it might be worth taking a good look at opera:config#Colors to see if any of those look like the text color.

    The addressbar gray is also hard-coded. 😞

  • Thanks Frenzie for the reply. I changed the colors to no avail. However running in X11 mode could maybe solve the problem, if I judge by the drastic effect it had on the File Open/Save dialog. I will ask how to do it on the Linux forum which I finally found. For such a simple annoyance however, it would be a complete change of look and feel, probably not for the better,

    Cheers,

  • Originally posted by alxobr:

    Now I still have to find out how to run the whole Opera in X11 mode.

    This confuses me. Did you restart Opera?

  • In Opera for Linux there is an extra section in opera:config which only has an effect in X11 mode, it allows you to change all those colors Opera would normally get from your desktop. Unfortunately I'm currently in Windows so of course can't even see this section to identify the exact name, it was something like "Interface Colors" though. Look through the sections and see if you can find it. That should allow you to change the "gray on gray" text ...

  • Originally posted by sgunhouse:

    In Opera for Linux there is an extra section in opera:config which only has an effect in X11 mode.

    Thanks a lot sgunhouse for your very pertinent answer. I did not find how to drop to X11 mode (with the exception of the file chooser in X11 mode) so my Opera is still in GTK mode. However your suggestion allowed me to find an "Interface colors" section in opera:config and I was then pretty confident it would solve my problem. I changed all the gray colors into bright colors and restarted to test... Then it was Carnival but... the status bar was still gray on gray!

    Despite this, my problem is now SOLVED. Since I always had the status bar active, I hadn’t noticed that, when it is disabled, there is a nice tooltip with the address popping up in black on white. Actually I barely needed the status bar for anything else, since Opera allows us to zoom in and out through the keyboard, which is way more efficient than the slider in the status bar.

    Thanks again to all who replied! Your help was very much appreciated and I learned things.

    Cheers,

    Alexandre

  • You are in X11 mode if Interface Colors has any effect. You could run Opera with no desktop at all (start up Linux in text mode, then do "startX opera") and it would work fine. Mind you, if you like you can right-click on the tab bar and disable "Show border" to remove your desktop's window frame ... but then you won't be able to drag the window by the frame (obviously).

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.