Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Ongoing security issue,

  • Some months ago my Opera (Windows 7 32bit) became unusable.
    Before every website I wanted to contact I would have to accept a series of prompts to approve each particular site on the route to the one I wanted. This is still current - hence this access to your forum via Firefox.
    My 'old' Opera had superb bookmarking, unlike Firefox! However it does look as if that issue has been fixed in Opera with the bookmarks in a sidebar instead of full screen.
    So, please tell me how I can get rid of the 'Security Issue' prompts,

    ![alt text](0_1550769263742_SecurityIssue.JPG image url)

  • Is spamarrest the site you were trying to visit?

    In principle, there should be a button on one of the other tabs in that dialog to add the certificate to Opera's certificate store. But if the warning is a real issue you should fix the problem and not just ignore it.

  • Are you getting that message when you access this forum?

  • @leocg said in Ongoing security issue,:
    For example:
    To access 'forums.opera.com' I have to approve:
    www.gravatar.com then
    www.google-analytics.com then
    www.opera.com then
    Then when I click on 'Login' to post this reply I have to approve another lot.
    Then after I login I have to approve another lot.

    This is brief compared to some of the other sites I have tried to access.

    Are you getting that message when you access this forum?

  • What about other sites? If you are getting that warning of the screen shot, you should start looking for malwares in your system and network.

  • @leocg . It occurs with every site I try to visit. Absolutely nothing like it on FireFox.
    I have Kaspersky Total Security functioning on my PC.
    How do I check for Malware, etc ?

  • And you always see that dialog mentioning spamarrest?

    If so, try to disable all your security softwares.

  • @pjbw127 Have you ever installed Spam Arrest on your system for filtering against eMail spam on any of your eMail accounts? From https://www.lifewire.com/spam-arrest-filtering-service-1166355: "Spam Arrest removes all mail from senders not yet approved before you download it or access it through Spam Arrest's 1 GB online web-based email service. ... Spam Arrest checks and cleans up to three POP or IMAP email accounts periodically. Works as a POP proxy service between your email client and your POP email account."

    Given that Spam Arrest employs POP proxy techniques, it may somehow be getting entangled in the process of vetting https certificates - which is what your original Security Issue message seems to refer to. If you've never installed Spam Arrest and you're getting this on all visited websites, there's something else going on such as malware, etc.

  • @blackbird71 said in Ongoing security issue,:

    there's something else going on such as malware, etc.

    Yes, I have Spam Arrest installed - invaluable !
    It looks as if I am stuck with FireFox in my Windows 7. This all works perfectly with Spam Arrest and Kasperky. I do miss the old Opera Bookmarking though.

  • @pjbw127 said in Ongoing security issue,:

    It looks as if I am stuck with FireFox in my Windows 7. This all works perfectly with Spam Arrest and Kasperky.

    Ok, but if you want to get to the bottom of things, you'll need to disable those (one at a time) to see if one is causing the issue with Opera.

    I assume your time, date, time zone and daylight savings settings are correct. If not, fix them (even if things work fine in Firefox).

    In the Control Panel, goto "Internet Options". On the "connections" tab, click "LAN" settings. Does anything (like SpamArrest) have a proxy turned on? If so, disable the proxy and disable "automatically detect settings". to see if that makes a difference.

    In your Network Settings under Network Connections, right-click on your ethernet or wifi adapter and goto "properties". Then, check the properties of your TCP/IP connections (both 4 and 6) and make sure IP and DNS are set to automatic (unless you know they're supposed to be set to something specific).

    Look at the file "C:\Windows\System32\drivers\etc\hosts" in Notepad and make sure there are no active entries (non-blank lines without # at the start). If there are, you need to fix that, save and restart Windows.

    Do you have Bitdefender and or Sandboxie on your system too?

    Also note that things working fine in Firefox might not mean too much. It uses its own network stack and might not be using the system's proxy settings. You can check the proxy part in "Options -> General -> Network Settings -> Settings" in Firefox to see. But, even if Firefox isn't set to "No Proxy", it is still using its own network stack instead of the one Windows uses. You need to compare with other Chromium-based browsers like Chrome, Chromium, Vivaldi and Brave that use the system's network stack like Opera does.

    Also, in Opera, download the Opera installer, launch it, click "options" set "install path" to a folder on your desktop, set "install for" to "standalone installation" and install. In that Opera, don't enable Opera Sync or VPN and don't import anything. Test in that Opera. If it works fine there, it means something is messed up in your normal Opera profile. If it still doesn't work there, goto the URL opera://extensions in that Opera and make sure there are no extensions (like ones for Spam Arrest etc.) that got installed on you.

    Another thing you can try is to temporarily create a new user account on Windows, log into it and test Opera there to see if there's a difference.

    Some testing to do, but it should help narrow things down. It's definitely something interfering with Opera.

Log in to reply