Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Clicking Links in Skype Won't Open Opera

  • I figured I'd post this to help anyone else with the problem. In Windows 7 if I have Opera set as default browser any links I click on in a Skype conversation will pop an error in Skype instead of opening in Opera. Long goose chase short what I found out was that because of the odd way Opera puts itself in the registry making it default doesn't actually default all protocols to it. So two key ones miss out, HTTP and HTTPS, which can be seen in the Control Panel->Default Programs->Set Associations section. You can change them to FireFox, IE, or Chrome, but Opera doesn't appear as an option because of that registry oddity I mentioned earlier.

    So here's what you can do. Mark HTTP and HTTPS as opening in Chrome then copy the files from the Opera Launcher directory in C:\Users_username_\AppData\Local\Programs\Opera\launcher.exe to the Chrome directory in your Program Files. Then rename the Chrome executable as ChromeB or somesuch. Then rename the launcher.exe file to chrome which will trick the computer into opening your skype link (or any http/https link) in Opera instead of getting errors.

    Or Opera could fix their registry entries 😉 just saying.

  • On Windows 10 x64 for Opera x64 installed for all users (requires admin to install that way):

    HTTP and HTTPS are listed in "HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\OperaStable\Capabilities\UrlAssociations"

    OperaStable is set as the value for the (Default) string in "HKEY_CURRENT_USER\Software\Clients\StartMenuInternet".

    Opera Stable is listed in "HKEY_LOCAL_MACHINE\SOFTWARE\RegisteredApplications" and points to "SOFTWARE\Clients\StartMenuInternet\OperaStable\Capabilities".

    There's an OperaStable handler in "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\OperaStable\shell\open\command", "HKEY_CURRENT_USER\Software\Classes\OperaStable\shell\open\command" and "HKEY_CLASSES_ROOT\OperaStable\shell\open\command" point to the correct exe.

    HTTP and HTTPS are available for Opera in "Set defaults by app". Opera is available in "Choose defaults by protocol" for HTTP and HTTPS.

    When setting Opera as the default browser, these are not modified:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\http
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\https
    HKEY_CURRENT_USER\Software\Classes\http
    HKEY_CURRENT_USER\Software\Classes\https
    HKEY_CLASSES_ROOT\http
    HKEY_CLASSES_ROOT\https

    , but changes to those are not needed on Windows 10. Maybe on Windows 7 though. For example, the exe in the command key for the HKEY_CURRENT_USER ones might have to point to Opera's launcher.exe. You still shouldn't have to mess with the local machine ones though.

  • @burnout426 @baerjo85
    This is all a bit beyond me but seems related to my issue. I have Windows 7 Pro 64 with Opera set as my default browser. However, when I click certain links in Opera, Chrome will open. The most recent example was the "Contact Us" link at the bottom of a Help page for Inc. magazine (https://incmagazine.zendesk.com/hc/en-us). When I clicked it, Chrome opened with what looked like an email address in the address bar. I went to the Default Programs>Set Association section. I didn't notice HTTP or HTTPS, but there were several associations to a Chrome HTML document: MAILTO, MMS, NEWS NNTP, TEL, and WEBCAL. I was able to associate MAILTO and WEBCAL to Opera Web Document, but Opera wasn't an option for the others. Now, unfortunately, when I click the Contact Us link on the Inc. magazine Help page, nothing happens. Can anyone help?

    0_1540974936011_associations.jpg

  • @yeltommo mailto should be associated with an email client? What email client do you use?

    The only reason mailto should be associated with Opera is if you use a webmail service, the service asked you if you want it to handle mailto links, and you said yes. Then, you'd set mailto in Windows to open in Opera so that mailto links outside of Opera will open Opera and then load the webmail service in Opera.

    Goto the URL opera://settings/handlers in Opera. Are there any handlers in there for 'mailto"? What email client or webmail do you want email links to open in? The answer to that will tell you what you need to do.

  • @burnout426 said in Clicking Links in Skype Won't Open Opera:

    opera://settings/handlers

    Thank you for trying to help. I use Gmail. I went to the settins you suggested and am including a screenshot. Clicking "Contact Us" on the Inc. Magazine help page does not open Gmail, but if I right-click on the link, I'm given the option to copy the (invisible) email address. I did this, opened Gmail, and then pasted the address into a new email.0_1541057196721_Operahandlers.jpg

  • @yeltommo First, go to default apps/default programs in Windows and goto "choose default apps by protocol". Then, set "mailto" to Opera. Then, go back into the handlers in Opera, click the 3 dots to the right and choose "set as default". Then, you should see "Default" underneath mail.google.com. Then mailto links will work.

  • @burnout426

    Had done the first step already. Did the second, and now it works. Thanks again.