Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Stopping opera from using default system proxy

  • Hello,
    I am trying to stop opera from using the default system proxy meaning the Internet Explorer proxy settings, after searching the web for a solution i ended up with adding
    --no-proxy-server="
    To the end of the opera ".exe" target, which solved my problem, now here is the issue, i mostly use private window and i open this windows by right clicking the icon on the task bar and choosing "new private window", when i do this, the
    --no-proxy-server="
    does not work ! and the opera goes back to using Internet Explorer proxy setting !, is there a way around this ?, is there a better way to stop opera from using the default proxy settings ?, i wish there was a simple check box for this in the settings menu... .
    Thanks.

  • I can confirm. *If* Opera is closed, right-clicking on the pinned taskbar icon with (with the modified target) and choosing "new private window" does not use the command-line arguments.

    I don't know where the Jump List Tasks shell links are defined, so not sure if you can modify them to add --no-proxy-server there too.

  • @burnout426 I see, how about creating a new shortcut and giving it both the command for no proxy and private window, and then pinning that new shortcut to the task bar and then using that to open a new private window with no proxy ?, do you know what kind of modification i need make to the target so it opens in private state instead of normal state ?, Thanks.

  • @ahmadi3d said in Stopping opera from using default system proxy:

    I see, how about creating a new shortcut and giving it both the command for no proxy and private window,

    That should work (for the normal open command by left-clicking etc.). Just add --private in addition to --no-proxy-server.

  • @burnout426 said in Stopping opera from using default system proxy:

    I don't know where the Jump List Tasks shell links are defined, so not sure if you can modify them to add --no-proxy-server there too.

    I see some info here, but that involves editing some binary files etc., and I don't even know if that'll work.

  • @burnout426 The code below works when opening with the normal left clicking, duo i was not able to add both shortcuts to the task bar and i had to remove the previous one and only add the one with private & no proxy command.
    Here is the code :
    "C:\Program Files\Opera\launcher.exe" --no-proxy-server= --private

    In the end i really hope the Opera adds a simple option to switch between "Using default system proxy" and "not using any proxy" in the settings, i might be mistaken by i think i had seen this option in the earlier versions of the new opera, and i think it has been removed recently, but i still should probably suggest this as a feature in the suggestions thread.
    Thanks for your helps.