Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera 54.0.2952.41: Streaming videos don't work anymore

  • @denisftw I have lost count of the number of different solutions that have been put forward for these problems, all involving somehow obtaining a different version of which may not work with any other piece of software, and which can not be relied on to work with a particular version of Opera.

    We're told it's because of patents, or mismatched library versions, or a library version needed specially for the new version of Opera which hasn't been released yet (and that all seems to miss the whole point of a library).

    I am getting confused, and I am beginning to doubt if anyone else really knows a reliable answer. There seems to be too much of "It works for me so it must work for everyone."

    I am trying to stay polite, but if "Tee-Emm" were still around and were dealing with computers, an award of The Most Highly Derogatory Order of the Irremovable Finger would already be in the post. Some of you deserve Season Tickets for your local ambulance service. The gabbling puts me in mind of a flock of chickens arguing over which end of the egg to to hatch from.

    The most reliable fix seem to be to stop using Opera to read Twitter.

  • @zhochaka That's why it is useful to understand the root of the problem. If you read the old @jimunderscorep's post, you will see that the problem is that the new version of the codecs is not yet in the Ubuntu repo. Since the repo is not maintained by Opera developers, there is no reason to blame them. In my opinion, Opera shouldn't release a new version to the stable channel until necessary codecs arrive, but this is an operational problem and has nothing to do with the quality of the product itself.

    Similarly, although obtaining a new version of libffmpeg and copying it manually might work, it is not a good solution. However, if we take into account that Opera 54 was released to the channel too early (relative to codecs), the logical solution is to roll back Opera itself and put it on hold until the Ubuntu team pushes new libffmpeg to their repo, and this was exactly what I did 2 weeks ago and described in this post:

  • @zhochaka As explained, it's a legal issue that leads to a technical one.

  • @leocg And it's not a new problem. It has happened before. It's a pattern of repeated failure. Is there no web page on this site that you can link to, rather than just saying problem solved?

    If it's a legal problem, I hope somebody has checked with a competent lawyer, because this wouldn't be the first time some competent professional has just been wrong about the law.

  • @zhochaka If people followed the rules, they probably would find the several topics on this subject and get a solution.

    I could create a FAQ topic on the Opera for Linux forum and include the information but my experience says that many people will not read it.

  • @leocg Opera is the only browser whose users are forced to use certain "rules ... to find ... a solution" to make this browser fully functional!
    Users of vivaldi, firefox, slimjet and many other browsers simply have to use it ...

  • @bombacha said in Opera 54.0.2952.41: Streaming videos don't work anymore:

    @mklinuxuser said in Opera 54.0.2952.41: Streaming videos don't work anymore:

    @burnout426 said in Opera 54.0.2952.41: Streaming videos don't work anymore:

    Try 54.0.2952.46. There's a video fix in the changelog.

    After getting it all working I updated to that version - videos on Facebook broken again. Now there is an other release
    (54.0.2952.51) available so will try that. If it is still broken I will try copying the same ffmpeg file again! What a palaver!

    Yes, the libffmpeg get replaced in every update, here is what you can do.

    • Download the last libffmpeg from here and extract some place.
    • Do sudo mkdir -p /usr/lib/chromium-browser
    • Copy the to that directory with sudo cp /usr/lib/chromium-browser
    • Just to make sure run sudo chmod 555 /usr/lib/chromium-browser/ followed by sudo ldconfig

    That will keep you safe for a while unless there is some huge change in the libffmpeg.

    Opera look in to this places for libffmpeg by default:

    cat /usr/lib/x86_64-linux-gnu/opera/resources/ffmpeg_preload_config.json

    Why use nwjs-ffmpeg instead of chromium-codecs package?
    Because nwjs-ffmpeg comes complete (11 MB) and works with linux distribution, chromium-codecs is about 3 MB and even if you installed over Debian (my case) it doesn't work for some reason.

    Opera was updated to 54.0.2952.54, after the procedure above, there was no need to copy or download anything.
    Everything is working as expected.

  • Maybe I'm oversimplifying, but I have ~10,000 customers out there who we have told to use and support Opera, Now I'm getting deluged with messages regarding facebook/twitter etc not playing videos. I've found no easy fix that a customer can do, and I'm not signing up for modding that many browsers. We are going to have to switch customers to Google Chrome, and that breaks my heart. I wish you had taken into consideration the priorities of the customer (websites working) over possible vulns that might be rare.

  • Would be nice to have a script that detects the version of Chromium that Opera is using and fetches the latest compatible and installs it (in Opera's lib_extra folder so it doesn't interfere with any other programs and the version they need etc.).

  • @burnout426 said in Opera 54.0.2952.41: Streaming videos don't work anymore:

    Would be nice to have a script that detects the version of Chromium that Opera is using and fetches the latest compatible and installs it (in Opera's lib_extra folder so it doesn't interfere with any other programs and the version they need etc.).

    For thouse outside the Ubuntu gang like Debian, Slackware, etc. Is possible to do this with cron once a month or whatever download the script would check the version, user system (32 or 64 bit), download, extract and install. No need for user interaction.

    From my experience on Debian, you don't have to update that file to often.

    Too bad I don't know how to code, but it shouldn't be a hard script to create.

  • Updating...
    Opera version 54.0.2952.60 is working just fine!

  • @bombacha +1 here!

    I don't have Chromium installed and Opera is seems to be playing html5 just fine!

  • @bombacha agree! works fine from scratch 🙂

  • On 54.0.2952.64 H.264 does not work.
    that's it. I'm tired of searching solution every few months.

  • Just to make sure!
    Opera version 54.0.2952.64 is working just fine!
    Still using the same

  • Solution for Manjaro/Arch Linux.

    In my case it doesn't work to play videos on facebook. Thank you to the user of the @appdevsw, he led me to the right track. I tested my solution at Manjaro. Probably it will also work on Arch.

    Install the missing codecs: opera-ffmpeg-codecs.
    After installation, restart the opera.

  • @bombacha in mine case the plugins are cousing Opera to crash I got similair screen to that
    I use Opera 64 bit version 56.0.3051.104. on Debian Stretch. I'v tried 4 different revisions of I eaven tried the 32 bit, the Problem is always there.

  • What versions of libffmpeg did you try and where did you get them from? 32bit libs do not work on 64 bit apps in general btw, not only on opera.

    Also, the crash of the built in preferences page has nothing to do with libffmpeg.

  • I'v tried 0.33.(1,2,3,4) and 0.34.0 libffmpg that I'v got from here:
    (the screen was for reference only). Youtube crashes whenever I copy libffmpeg to Opera directory. If the ffmpeg is deleted videos are not working but the site does not crush.

  • How can you tell that those libffmpeg... libs for nodejs are built from the same chromium source opera is built on?
    You can't know. And that is exactly what I say on the bottom of my post on my signature

    Expert's advice on the above
    From time to time, someone will post a "solution" to the libffmpeg problem. This will either be "install this ubuntu's chromium ffmpeg codecs package by hand to get the... precious html5 support" or "get that tar,gz from herecura's repo, untar it and move libffmpeg to the right place to make it work".
    Both are wrong because they refer to packages built for a different distro (ubuntu in the first case, arch in the second), and definitely built with a different set of libraries and compilers. Do not do that unless you want to break your system or browser.

    The only difference is that you get the libffmpeg built for nodejs, which is also completely irrelevant to the ones mentioned above.