Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera is unusable (freezing and laggy) on High DPI display monitor

  • As far back as Opera 40 I have noticed this issue. It is getting worse as more websites are getting affected. The issue is when I use Opera with my laptop screen (UHD 4k display), all of Opera built-in feature pages (Settings, Extensions, History, News feed ...) are freezing and laggy. If a click a button/scroll on those pages, it takes 5 seconds for that click to register and the CPU revs up all the time. I have to close all of the pages for Opera to return to normal.

    Recently I noticed websites can be affected as well, some of examples I list here are from ebays. If I navigate to these websites, scroll to the middle of the page that's when the problem starts. Again, I have to close the page for Opera to return to normal. Say middle click on the tab, 5 seconds later the tab is closed.

    https://www.ebay.com/itm/LED-Display-Module-Delay-Timer-Relay-Control-Programmable-Switch-Car-Buzzer-12V/272301547347?epid=508943557&hash=item3f666fdf53:g:SKAAAOSwEjFXf2sg

    https://www.ebay.com/itm/12V-DC-Delay-Relay-Delay-Turn-on-Delay-Turn-off-Switch-Module-with-Timer/172524324192?hash=item282b404560:g:5v0AAOSwWxNYnSjB

    The reason I firmly believe this is DPI scaling issue is this problem only happens when I use Opera with High DPI screen. If that same laptop, I plug to an external 1080p monitor then none of this issue happen. Opera is smooth and responsive like it should be. By the way, Chrome browser does not have this issue ☹ why Opera ?

    I have submitted a bug report with this number: DNAWIZ-29908. Please let me know what I can do to assist your testing.

  • @operahandsdown this may or may not help temporarily..

    rigt click opera shortcut - click properties - Compatibilty tab - Check the box (Disable display scaling on high DPI settings) or sumthing like that.. if it doesn't help leave unchecked..

    and or try this - go to Opera Settings > Advanced Settings > Browser - Scroll down under system, check box (Use Hardware Acceleration when available)

    If Opera is running with Hardware acceleration activated, see if disabling could help the issue to go away..

  • @nvmjustagirl Thank you so much for the suggestions ! Did not try the Compatibility setting but I went to Settings and saw the Hardware Acceleration unchecked so I checked it and restarted Opera. Now for practical purpose the issue no longer exists (although still can't compare with with the responsiveness and smoothness when scrolling on a 1080p display monitor).
    Finally after so many revisions I have this problem fixed thank to you! 😌

  • Would like to report that with Hardware Acceleration enabled, Opera rendering engine seems to crash once in a while, when it does, the whole screen blacks out for a split second then comes back normal. But this is still manageable, just a minor annoyance.

  • @operahandsdown seems like Hardware Acceleration enabled works for you.. would ya mind & disable all extensions esp n e ad blockers.. then see if ya have blackouts..

    also it might help if ya could post what version of windows ya use and if 32 or 64 bit - same with opera version - and what graphics amd - intel - nvida.. Thanks

  • @nvmjustagirl I have disabled all extensions and confirmed blackouts still happened. I have Opera 53.0.2907.99 running on windows 10 EDU x64 build 17134. Graphics 1 Intel HD 4600 driver ver 10.18.15.4279, Graphics 2 Nvidia GTX 960M driver ver 24.21.13.9731. I don't think the Nvidia graphics was running while I was using Opera. If it was I would have noticed activity in the tray bar.

  • @operahandsdown what model is computer desktop laptop tablet.. hp - acer - dell, ect.. (guess 'n i7 or I5) looks like you're use 'n the computer's manufacturer for suggested drivers.. intel and nvida both got newer driver.. lottsa peeps install them and have no problems..

    while you're still work 'n with intel.. go ahead (if its no trouble) and disable the Nvidia's nView Desktop Manager thingy.. for a bit to check for blackouts

    does opera://gpu says that hardware acceleration is being used for video decode ?..

    Check the log messages on the bottom too.. n e error listed under 'log messages'?..

  • @nvmjustagirl I have captured the crash log in this paste:
    https://pastebin.com/LeBjsezN
    My laptop is Lenovo Y50 with UHD touch screen, intel i7 4710. I have never had a problem with video driver with any apps before. Just this Opera seemed to crash once in a while.

    The message seemed to indicate:
    Trying to call glGetShaderPrecisionFormat without current GL context
    Trying to call glClientWaitSync without current GL context
    Trying to call glGetError without current GL context
    GpuProcessHostUIShim: The GPU process crashed!

    This has happened randomly, and not on a particular website, eg: this crash log was captured when I was checking gmail.

  • @operahandsdown In the opera settings when box is checked Use hardware acceleration when available

    then when ya go here opera://gpu/
    and look at the 1st Heading called the (Graphics Feature Status) you should see most of this Hardware accelerated..

    Canvas: Hardware accelerated
    CheckerImaging: Disabled
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Force enabled
    Native GpuMemoryBuffers: Hardware accelerated
    Rasterization: Hardware accelerated
    Surface Synchronization: Enabled
    Video Decode: Hardware accelerated
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated

    So this Error means - GpuProcessHostUIShim: The GPU process crashed! = disable hardware acceleration.. *in opera 's settings uncheck box Use hardware acceleration when available

    try 4K reduced to Full HD..

    Try enabling opera://flags/#ignore-gpu-blacklist

    Also right click opera shortcut - click properties - and in the target field "C:\Program Files (x86)\Opera\Laucher.exe" (add a space 1st) --disable-gpu-sandbox

    Example
    "C:\Program Files (x86)\Opera\launcher.exe" --disable-gpu-sandbox

    the other Gl context errors - Trying to call glGetError without current GL context = have 'n to do with OpenGL

    but looks like ya can use hardware acceleration most of the time..

    it could be a driver problem or a chromium problem *chrome.. or win 10

    intel's GPU is intended for routine and battery mode. The GeForce GPU is enabled in performance-driven applications, such as computer games. Switching is automatic, but you can always intervene manually..*i think..

    ummm.. in games the GeForce GTX 860M GPUs in the Y50 models do not clock at their maximum possible speeds.. dunno bout 960m

    ya should test a little more by doing each graphic card independently of each other esp switchable graphics.. *like disable nvida.. then when testing nvida disable intel..

    operahandsdown 15 days ago
    As far back as Opera 40 I have noticed this issue. It is getting worse as more websites are getting affected. The issue is when I use Opera with my laptop screen (UHD 4k display), all of Opera built-in feature pages (Settings, Extensions, History, News feed ...) are freezing and laggy. If a click a button/scroll on those pages, it takes 5 seconds for that click to register and the CPU revs up all the time. I have to close all of the pages for Opera to return to normal.

    Recently I noticed websites can be affected as well, some of examples I list here are from ebays. If I navigate to these websites, scroll to the middle of the page that's when the problem starts. Again, I have to close the page for Opera to return to normal. Say middle click on the tab, 5 seconds later the tab is closed.

    https://www.ebay.com/itm/LED-Display-Module-Delay-Timer-Relay-Control-Programmable-Switch-Car-Buzzer-12V/272301547347?epid=508943557&hash=item3f666fdf53:g:SKAAAOSwEjFXf2sg

    https://www.ebay.com/itm/12V-DC-Delay-Relay-Delay-Turn-on-Delay-Turn-off-Switch-Module-with-Timer/172524324192?hash=item282b404560:g:5v0AAOSwWxNYnSjB

    The reason I firmly believe this is DPI scaling issue is this problem only happens when I use Opera with High DPI screen. If that same laptop, I plug to an external 1080p monitor then none of this issue happen. Opera is smooth and responsive like it should be. By the way, Chrome browser does not have this issue ☹ why Opera ?

    I have submitted a bug report with this number: DNAWIZ-29908. Please let me know what I can do to assist your testing.

    All of this could be related also -

    i dunno if its been fixed - found here

    But the Y50 4k UHD 48hz had locked refresh rate and low notebook performance plus scalling issues..

    also the 48Hz lock has nothing to do with external displays or with the HDMI, in this case you get 60Hz on FullHD and 30Hz on 4K..

  • Today I upgrade to Opera 54 and still have this problem (with HW acceleration off). Finger crossed on Opera 55 maybe.

  • @operahandsdown ya might try this Update from Microsoft KB4284848

    this update should work with your version of windows.. take a look & read.. it may or may not help..

    For peeps that use switchable graphics..

    Note - It is normal for your screen to flicker or go blank for a few seconds when switching graphics processors..

  • @operahandsdown check this out.. may or may not help found here