Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Videos in Opera flashes after updating Windows 10 to version 1803

  • Hello all,
    I have a problem that started occuring after I've updated my Windows 10 to the latest version 1803. When I'm playing random videos on my Opera (youTube etc.), sometimes it happens that the whole screen starts flashing, or should I say turns off and on for a blink of an eye very fast. I think it mostly happen when I move the cursor while video is in fullscreen mode, but once the screen was blinking even after minimazing Opera and going to desktop.
    I've reinstalled the graphic drivers (both for integrated graphics card and GeForce), Opera and Adobe Flash player, but it didn't help.
    Can anybody help me please?

  • @yaro1986
    Try disabling hardware acceleration in Opera's advanced settings and see if that fixes it.
    If it does, try reinstalling the graphics drivers again. Did you uninstall and reinstall, or just reinstall them?
    If the latter, try completely removing them before reinstalling, that can make a difference over just reinstalling over the top of what's already there.
    🙂

  • Well, the good news is that disabling hardware acceleration helped - the screen stopped blinking.
    The bad news is that I completely unistalled and installed again both integrated graphics card and GeForce drivers and it didn't help - still problems with hardware acceleration 😞
    I will just stick with leaving it switched off, but something is definetely wrong.
    Maybe it's an issue that needs solving by Opera devs.
    If some kind of data is needed from my computer, let me know.

  • @yaro1986 What about Chrome and other Chromium based browsers?

  • @leocg I've installed Chrome and it has the same problem as Opera when using hardware acceleration 😞 Maybe it is a problem with drivers - they may not be compatible with v.1803 of Windows 10. Unfortunately I have the latest ones available through official Lenovo support. Theoretically I can download the drivers directly from Nvidia, but I'm a little afraid of it, cause when I tried it long time ago with my previous notebook, they didn't work at all.

  • @yaro1986
    For what it's worth, I've always downloaded drivers directly from manufacturers' websites, and never had any problem.
    Drivers offered by third parties, especially Microsoft, are often very out of date.
    🙂

  • @yaro1986 check if opera://gpu says something about it.

  • @davehawley
    I have installed the latest drivers from Nvidia page - no result 😞
    Unfortunately I could not install the latest drivers for integrated graphic, because my notebook wouldn't let me 😕 - the message was shown that "driver compability with this device has not been checked" and I couldn't do anything, even in administrator mode.
    I give up...

    @leocg - to be honest I don't know what to do with this wall of text and symbols 😛
    Maybe it wll be helpful for you, there are some problems found0_1527354228517_Przechwytywanie1.PNG
    0_1527354237251_Przechwytywanie2.PNG

  • @yaro1986 It seems OK. Any error listed under 'log messages'?

  • @leocg

    Log Messages
    GpuProcessHostUIShim: The GPU process exited normally. Everything is okay.

    It seems it is OK.
    I will do one more thing - I will install a game (cause currently I don't have any on the drive) and check if the drivers work fine with a game. If no, this will probably mean problem between drivers and updated Windows. If yes, the error have to be somehow connected with Chromium based browsers.
    Is it possible that antivirus may be a source of a problem? I recently read some news that Avast breaks something in v.1803. Personally I use ESET Internet Security, but who knows...

  • @yaro1986 It may be a Chromium issue.

  • @leocg
    OK, I have installed a game and it works fine - no blinking or low performance that could mean problems with graphic drivers.
    I give up - I will turn off the hardware acceleration in Opera and wait for updated version.
    Should I inform Opera devs about the problem?

  • @yaro1986
    It sounds like your system is fundamentally OK.
    It would be worth logging this with Opera, even if it is an issue with the Chromium engine, they will know how to pass it on to the necessary people at the Chromium project.
    🙂

  • @yaro1986 If Chrome shows the same then it's probably a Chromium issue.

  • @yaro1986 i dunno if n e of this will help.. but here goes lol

    To turn this on - Native GpuMemoryBuffers = on the opera shortcut right click properties & in target field add this at the end of it - (a space 1st) --enable-native-gpu-memory-buffers

    Note - in opera settings even if ya turn on/off Use hardware acceleration when available

    Native GpuMemoryBuffers will use Hardware accelerated instead of software..

    Note - if Use hardware acceleration when available is off most of these also will be Software only. Hardware acceleration disabled..

    Canvas: Hardware accelerated
    CheckerImaging: Disabled
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Force enabled
    Native GpuMemoryBuffers: Hardware accelerated
    Rasterization: Software only. Hardware acceleration disabled
    Surface Synchronization: Enabled
    Video Decode: Software only. Hardware acceleration disabled = Software only. Hardware acceleration disabled
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated

    But in opera setting's - ya could leave Use hardware acceleration when available Enabled - and disable flags one @ a time... like ya would do with extensions if one was cause 'n troubles..

    Example - Video Decode: Software only. Hardware acceleration disabled = Software only. Hardware acceleration disabled

    Even tho Use hardware acceleration when available is Enabled - i diasabled it with flag

    Here is flag's name..

    Hardware-accelerated video decode
    Hardware-accelerated video decode where available. – Mac, Windows

    #disable-accelerated-video-decode

    u can disable GPU rasterization and others..

    but if none helps.. in opera settings ya may be stuck with Disable - Use hardware acceleration when available..

    If ya do find a flag or two that helps.. please let us know .. thanks.

  • @nvmjustagirl
    God Almighty, this is some serious sh*t 😃 Don't have time for this today, but as soon as I find some time (and hopefully have skills to actually do it) I will tell you about the outcome.
    Thank you for taking the time to write this detailed instructions.

  • @yaro1986 i know its time comsuming.. and may be a waste of time.. i think this affects most chromium browser.. the Opera Team is limited i guess because Microsoft is the Villain !..

    seems like they have left lottsa graphic cards out that are no longer compatible with windows.. and i'd say lottsa peeps got a few opinions to say about that !..

    Btw you're welcome

  • @davehawley Thank you Dave saved me from big troubles

  • @fuad47
    You're welcome, I'm glad it helped you.
    🙂