Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Mouse gestures and context menu problem

  • The problem:
    When I hold down the right mouse button. The context menu opens.
    Blocking mouse gestures if I move the mouse over it.

    I can still use mouse gestures, to an extent. As long as it does not move over the context menu. Which is sorta hard to do.

    What should happen:
    When I hold down the right mouse button, the gestures circle should show up. Or if I hold and release, then the context menu should show up.

    This is the way it's been for years, up until yesterday.

    What I have tried so far:

    • Restarting.
    • Disabling all my extensions, then restarted.
    • Disable then mouse gestures option, then restarted.
    • And enabled again, and then restarted again.
    • Googling, I didn't find anything relevant to my situation.
    • Tried looking on the forums here if anyone else had the same issue. Again, didn't find anything relevant.

    Version: 52.0.2871.64 - Opera is up to date
    Update stream: Stable
    System: Windows 10 64-bit

    Any help would be greatly appreciated on this.
    And if there is any more info I could provide, then I'll do my best to supply.

    Thank you!

  • @norway174 Did you try checking your mouse buttons settings?

    And I may be wrong but I guess the gestures circle no longer exist since a while. You simply press and hold the right button and do the gesture.

  • @leocg I didn't consider that. As it's still working as in intended for other apps/on the desktop.
    The context menu only shows when I release the right mouse button. Like normal.

    But I checked the settings, just in case. And I didn't find any option related to when the context menu should show on a right click.

    So I tested it to make sure, again. And now something else is happening. When I right click, and hold. The context menu appears, then goes away. Then when I release the right mouse button, it shows up. Like normal.

    So it appears this may not have been the correct place to post for help.

    Edit:
    So now it's back to the first way again. I really don't know what's happening here. It was also fine for a second. Even in Opera. I could use mouse gestures like before. But now it's back with the context menu again.
    And it's fine in other apps, and on the desktop.

  • @norway174 Did you try un-installing and re-installing your mouse drivers?

    Does the problem happens with a clean Opera profile?

  • @leocg So, I googled some more.
    And I found a tip I should probably have done from the beginning.

    Which is to try another mouse, and I did.

    I probably should have done that before I started re-installing my mouse drivers. xD

    Anyway, it is an old mouse. Served me well for years.
    So it's probably time to get a new one anyway.

    Strange it only happens in Opera, but it's probably only going to get worse. 😕

    Thanks for your help at least!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.