:tools: Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, December 14, starting from 10:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

[Opera 21] Annoying new behavior with [CTRL] + [Backspace]

  • Hi,

    before Opera 21 I could use [CTRL] + [Backspace] to delete a complete word when typing in a formular. Now it is just "Back in the History".

    Is it possible to change this anywhere?

  • before Opera 21 I could use [CTRL] + [Backspace] to delete a complete word when typing in a formular

    Using Opera Developer 22 here and ctrl + backspace seems to delete the word on the left, at least on a text field like this one.

    Also the same on the address bar.

  • Ctrl Backspace works in my Opera 21 as "Delete left word" in Forms, in Addressbar and text fields on websites.

    May be some extension installe by you hijacks the keycodes for Ctrl Backspace.

  • I have the same problem.

    Facebook from Opera 21 began to display the following message:

    "You haven't sent your message yet. Do you want to leave without sending?"

    1. Open the example https://www.facebook.com/Opera (on the home page it does not happen)

    2. Start typing a comment, post or message in the chat

    3. Press CTRL + BACKSPACE. Instead of deleting the last word appears show message "You haven't sent your message yet. Do you want to leave without sending?"

    It's a bug or feature?

    Instead of deleting the last word comes back to the previous URL.

    I use the migrated profile of Opera 12, but I tried to establish a clear profile of Opera 21 and there is also a problem showed.

    The problem happens every time - even when switched off/on "Enable advanced keyboard shortcuts"

    So far, I feel that it's happening "randomly". Select "Enable advanced keyboard shortcuts" can be on or off. So far, I could not exactly reproduce the problem, but it also resulted in a clean new profile.

    I write about it here too: http://blogs.opera.com/desktop/2014/05/opera-21-desktop-released-aura-powered/#comment-1372549394

  • Hm, thanks for your answers.

    I just installed the update. This occurs at home and work. Maybe I should compare the installed extensions.

  • Same here since Opera 21.

    Hitting CTRL + backspace in any text field makes Opera to go back to previous page.

    Pretty annoying... Filled a bug report for that -> DNA-20122

    [Mod note: please do not post email addresses in forums as it will only make them be filled with spam]

  • I had the same problem. Sorry to say, but I changed a lot of things and I don't know with one actually helped.
    For sure, I have Opera 21.0 on Windows and Ctrl+Backspace works fine now.
    I know disabled all add-ons and disabled advanced keyboard shortcuts in options.
    Try and share results, please.

  • I'm having the same problem for the last few days, in Opera 21 and Opera Next. I habitually press ctrl+backspace all the time when typing sentences as pretty much everything these days handles it for deleting words, so this is driving me mad! I have often had to re-write things several times because I keep forgetting ctrl+backspace does not do what is expected.

    It is mind-boggling as to why they would replace this de facto standard keyboard shortcut with a completely unrelated feature. This is a serious regression IMO.

  • I tested control backspace in the "Find in Page feature," and it worked fine there, deleted the words I had just typed. I'm using Opera 21. So :) I don't have the bug yet.

  • @lem729: It seems to work fine there. The problem is when typing in a text box in a web page, like when typing in Gmail, or in a comment right here. For whatever reason it doesn't happen on all websites, e.g. Twitter or TweetDeck.

  • Typing in gmail worked fine for me (that is, the control backspace). I'm using the Gmelius extension for Opera., so I don't know if that made a difference. But it also worked fine for me in this text box, writing to you, so I must not have that bug.

  • I've found a solution here:
    http://superuser.com/questions/726337/is-there-a-way-to-disable-ctrlbackspace-behavior-in-opera-21-0-1432-0

    You have to edit your "%APPDATA%\Opera Software\Opera Stable\Preferences" file.
    There you should insert:

    "Keybindings": {
    "Basic": {
    "ParentDirectory": [ "Ctrl+Shift+Backspace" ]
    }
    },

    after the first curly bracket (literally into line 2).

    It will override the default key binding (Ctrl+Backspace) and won't bother you.

    If you have "Preferences.bad" file created in the directory next to original "Preferences" - something is not valid in the edited file and it falls back to the original version, saving the non-working one.

    PS. Looks like it was a planned change:

    DNA-9014 Going to parent directory with Ctrl+BS should work (http://blogs.opera.com/desktop/changelog21/)

    Although for me it's totally inconvenient.

  • I also encountered some changes related to shortcuts and found a workaround that doesn't require to actually change the default Opera shortcut. In my case, manually setting up the shortcut in the preferences using the same shortcut actually fixed my issue.
    So in your case, instead of setting up a different shortcut, try entering the default one in the preferences:
    "Keybindings": { "Basic": { "ParentDirectory": [ "Ctrl+Backspace" ] } },

    I haven't tested that, but maybe you're seeing the same root issue as I did and it works for you too. For reference, here's the thread I posted in:
    https://forums.opera.com/topic/2723/opera-21-suddenly-overriding-web-site-keyboard-shortcuts/3

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.