Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, June 27, starting from 07:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

Whatsapp Protocol

  • Someone help me. I've been getting the following error:
    0_1520023792353_2bf4e80e-ea02-4dd3-b57c-a6a8b94c2aa1-image.png
    How do I solve this problem?
    Thank you

  • @mvitoi Try associate the protocol with a program on Windows settings.

  • @leocg - Thanks.... if only I knew how! :face_with_cold_sweat:

  • @mvitoi if you using windows 10 try

    0_1520715572754_1.png

    0_1520715580794_2.png

    BUT, i not find this protocol on my pc...

    please say if you using it on windows 10 or 8 or 7... i will try to help

    when you get this message, how you get it..?

    you trying to access the side bar or "whatsapp web on site"?

  • @rodrigowbs
    I'm using Windows 7 - Professional. It's in English! Using Whatsapp web site.
    Thank youuuuuuuuuuuuuu!

  • @mvitoi Sorry for delayed message After some time trying to associate this protocol to any browser in a Virtual machine With windows 7 pro 64x

    i have interesting logs about this.

    1° this protocol is not associate with windows (can't be associated in system)

    2° with Google Chrome "Whatsapp://" do a request to XHTML Protocol, but without response.

    3° in this link

    https://api.whatsapp.com/send?phone=1111111111111&text=weelll i put web on this url#

    when you change "API" To "WEB" he redirect to whatsapp web page.
    0_1520801788611_23432432.png

    0_1520801808563_23432432111111.png

    BUT, for chat invites, i cant do this 😕

    i will continue my research about it..

    However i think it's a bug.
    I reported to Opera to view if have something to do about that.

    Again, sorry for delayed response.

  • @rodrigowbs
    Obrigadíssimo, Rodrigo. Vou fazer testes aqui também. Assim q tiver notícias, me avise, por favor.
    Um abraço!
    Marcelo

  • @rodrigowbs
    Rodrigo, IT WORKED!!!!!!!!! Thank youuuuuuuuuuuuuuuuuuuuu!!!!!! just typed "web" instead of api and it worked.:smiling_face_with_open_mouth_smiling_eyes:

  • @mvitoi Glad to help you 😃

    If you need anything, just talk.

    valeu jovem o/

  • @MVitoi Run this registry script (link) and the WhatsApp protocol will be added automatically on your Windows.

    Or create and manually run a .reg file with Notepad with the commands:

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\whatsapp]
    "URL Protocol"=""
    @="URL:whatsapp"
    "DefaultIcon"=""%localappdata%\WhatsApp\app.ico",1"

    [HKEY_CLASSES_ROOT\whatsapp\shell]

    [HKEY_CLASSES_ROOT\whatsapp\shell\open]

    [HKEY_CLASSES_ROOT\whatsapp\shell\open\command]
    @=""%localappdata%\WhatsApp\WhatsApp.exe" "%1""

  • @wignyalmeida said in Whatsapp Protocol:

    @MVitoi Run this registry script (link) and the WhatsApp protocol will be added automatically on your Windows.

    Or create and manually run a .reg file with Notepad with the commands:

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\whatsapp]
    "URL Protocol"=""
    @="URL:whatsapp"
    "DefaultIcon"=""%localappdata%\WhatsApp\app.ico",1"

    [HKEY_CLASSES_ROOT\whatsapp\shell]

    [HKEY_CLASSES_ROOT\whatsapp\shell\open]

    [HKEY_CLASSES_ROOT\whatsapp\shell\open\command]
    @=""%localappdata%\WhatsApp\WhatsApp.exe" "%1""

    I run the reg file but still the api protocol not working 😞

  • @passegua, sorry for the delay, but the solution to the problem is this:

    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\whatsapp]
    "URL Protocol"=""
    @="URL:whatsapp"
    
    [HKEY_CLASSES_ROOT\whatsapp\shell]
    
    [HKEY_CLASSES_ROOT\whatsapp\shell\open]
    
    [HKEY_CLASSES_ROOT\whatsapp\shell\open\command]
    @="\"C:\\Users\\wigny\\AppData\\Local\\WhatsApp\\WhatsApp.exe\" \"%1\""
    

    Create a .reg file with that content, but replace the wigny user with your user, and it will work.

Log in to reply