Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera autoruns at Windows boot with 4 tabs

  • @h06 Dittoo the above.

  • It's CarboniteUI.exe that triggers it at least. You can kill it in task manager and then launch Carbonite again to trigger the problem without a restart.

    Edit: When I reinstalled, I reinstalled both Opera Stable and Opera Developer. I installed Opera Developer last and Opera Developer's launcher.exe is the one that Carbonite is launching.

    launcher.exe gets added to the "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.Application" list.

  • @muharana said in Opera autoruns at Windows boot with 4 tabs:

    @blackbird71 ... To be clear, Opera, in my case, did not "install itself." I installed and then uninstalled it when it did not work well. And when the popups began, I started the aforementioned Microsoft thread, in the hopes that I'd discover what went wrong. ... We just need to know what that component is and how to get it back, if possible.

    Understood. My reply was with directed to a poster's assertion that Opera somehow installed itself 'spam-like' or malware-like onto a user's system. The record needed to be set straight on that point. It does appear that there's some kind of interaction between Opera's re-install and Carbonite (as @burnout426 has demonstrated) that needs to be sorted out and fixed.

  • I got Opera to stop launching by renaming "HKEY_CLASSES_ROOT\ProgID" to "offProgId".

    Does that work for anyone else?

    The key might reappear with the original name, but that seems to be the culprit so far for me.

  • @burnout426 said in Opera autoruns at Windows boot with 4 tabs:

    The key might reappear with the original name, but that seems to be the culprit so far for me.

    Yes. Opera Developer wasn't set as the default browser. When I set it as such, the ProgID key reappeared and caused the problem again.

  • I've experienced the same problem with the "progid:InternetExplorer.Application" message popping up. Sequence of events:

    • Installed Opera (to troubleshoot something for a client)
    • Uninstalled Opera
    • After uninstall, that progid message appeared on start up. I had to click ok 4 times (would pop up again after each "ok") before it would go away.
    • Uninstalled Carbonite (per the Microsoft forum post referred to above) and reinstalled Carbonite.
    • "progid" popup message stopped

    I'm running Win10 and Carbonite like everyone else. Never had this problem until I (unfortunately) installed Opera

  • @burnout426 said in Opera autoruns at Windows boot with 4 tabs:

    Yes. Opera Developer wasn't set as the default browser. When I set it as such, the ProgID key reappeared and caused the problem again.

    It also reappears when installing/upgrading Opera.

    Also, after deleting the ProgID key, I created a dummy one in its place and then set everything to DENY so that Opera wouldn't add its strings etc. to the key when you set it as the default browser. That worked. However, when I tested installing/upgrading Opera, Opera somehow wrote to the key anyway and messed up the permissions of the key where I could no longer delete the key. Took me a while, but I was able to delete the key again.

    Anyway, for users that are or already have uninstalled Opera, deleting "HKEY_CLASSES_ROOT\ProgID" should fix the issue. For users that want to keep Opera or reinstall Opera, you'll have to delete the key after every time you set Opera as the default browser or you install/upgrade Opera, (For now at least)

    Delete "HKEY_USERS.DEFAULT\Software\Classes\ProgID" too if it's there just for good measure.

  • @burnout426 said in Opera autoruns at Windows boot with 4 tabs:

    Delete "HKEY_USERS.DEFAULT\Software\Classes\ProgID" too if it's there just for good measure.

    Thanks burnout - this fixes the issue for me as well.
    I'll have to await Opera to release a new version without this bug before I can continue using opera again.

  • @burnout426 Thanks, burnout426! Deleting "HKEY_CLASSES_ROOT\ProgID" worked for me too. You're a champ!

  • @blackbird71 said in Opera autoruns at Windows boot with 4 tabs:

    Things like this don't "just happen", they happen for a reason.

    As far as I know, Opera was installed on my computer when I bought it. Of course, if that's true, why did it suddenly begin auto-starting?

    There's no malware on my computer. Maybe Opera piggybacks onto something else? I could have overlooked a tiny box that was already checked. Some programs try to sneak onto computers that way. But I hadn't installed anything recently, when this started happening.

    I'm going to be very, very careful to avoid Opera in the future, but I'm normally quite careful already. I tend to be paranoid about internet security. So I have no idea what happened in this case.

    I'm also hesitant to start screwing around with the registry, given that I know nothing about this stuff. I might just uninstall Carbonite and switch to a different backup service to see if that works. But we'll see. I certainly appreciate the comments here.

  • @wcg So whoever sold you the computer, had installed Opera. Or maybe the person who installed the OS and first programs on it.

    Regarding Opera have started to open on startup, something is triggering it like already saw here in this topic.

  • @team5d - Nevermind. That didn't fix it. Uninstalling Opera and uninstalling/reinstalling Carbonite did not get rid of the progid popup. It's still there. Argh!

  • @maryxyz said in Opera autoruns at Windows boot with 4 tabs:

    Thanks, burnout426! Deleting "HKEY_CLASSES_ROOT\ProgID" worked for me too

    Thanks for the confirmation. Here is a simple reg file that one can launch to get rid of the key. All it has in it is:

    [-HKEY_CLASSES_ROOT\ProgID]
    

    I tested it to make sure it works.

    I didn't test, but one could delete the key in a command prompt like this:

    REG DELETE "HKEY_CLASSES_ROOT\ProgID" /f
    

    One could also set up a startup entry or scheduled task (that runs before Carbonite) to delete the key at startup with that command

  • @burnout426 You're the best! Deleting this key seems to have done away with the error prompts at startup for me as well! Thanks so much 🙂

  • @burnout426 Thanks for the additional info, burnout. I'll file that for later reference if needed. You're help is so appreciated!

  • @burnout426 Just tried this - no change

  • @dowder46 woops - meant to say that I tried changing it to offprogID

  • @dowder46 Sorry, I would have written again sooner, but I had to op
    en Opera myself! And then, when it did open, it didn't open with extra tabs! All because I trusted you and ran your program! Burnout for President!

  • Hi, it's a bug in Opera, we're very sorry for inconvenience. We already have a patch for it thanks to your help on this forum. I hope to see the patch soon in stable stream.
    Thanks a lot (esp. @burnout426 )

  • Hello, I've been following this post and the Microsoft thread as Albertico mentioned 10 days ago at the top of this thread. I believe I have some other useful symptoms that can be added.

    Before I mention those symptoms, I would like to mention that I saw there is a new Opera update version "51.0.2830.40". So I redownloaded Opera and it is doing the same thing as the last update. Which is that it loads up tabs automatically at startup. I again uninstalled Opera and the other error message still appears at startup again. So if the new version that is out was suppose to be the fix, it did not fix the issue. I am looking forward to it being fixed since I would like to use Opera as my default browser again.

    Anyway, back to the added symptoms. I have a unique situation since Opera is working on my Windows 10 desktop (with carbonite) just fine. However, on my Windows 7 work desktop (also has carbonite), that is where Opera is not working.

    • Both desktops has/had Opera as default browser (currently uninstalled on Windows 7 until there is a fix).

    • Opera on my windows 7 after it was manually updated it had began auto loading tabs at startup, as others have stated. What I have not seen others mention is that these tabs do not ever load. I've tried closing all of them down to one tab and typing google.com and that eventually loads up but doesn't let me click anything to go to the next page. For example I can't click sign in to my email.

    • Something else I noticed on the windows 7 Opera in and out of fiddling with it when the error first came up and then again in and out of installing it seeing it its fixed yet.. I have some preset tabs to auto open, 4 to be exact. So when my Opera opens it opens those 4 plus 3 more and 1 speed dial tab. All of which never load as mentioned above. For the sake of less tabs opening I tried to set new tabs to just load google.com at opera startup. When trying to do this, the set tab section when I click to use current tabs, it is blank. However, it did manage to select to open just google.com.

    • Lastly, because Opera seemed like it was trying to load and partially got to google.com even though I couldn't click around. I figured I'd try clearing the cache and browser history just in case it is recalling loading bad links. So when I tried this, that also would not process my request. It would allow me to click to clear the cache and browser history but it would just get stuck in an endless loading.

    I think that sums up any input I can add for now that others have not yet mentioned. Aside from maybe digging deeper into comparing what my windows 10 desktop has or doesn't have compared to my windows 7. I would need to know what I should be looking for if that is the case. I don't really know to much about registry issues so I can't contribute there. But I can say that my windows 10 has Microsoft edge and windows 7 has internet explorer. I know I've seen comments saying carbonite runs on a component of Internet Explorer, I assume that same/similar component is in Edge? or maybe it is not which is why my windows 10 is running fine. Others mentioned they are having this issue on a windows 10 so im not sure where I got lucky in that regard but my windows 10 is running Opera version 51.0.2830.40 smoothly as default browser.

Log in to reply