Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

OPERA MAIL - no notifications when using IMAP

  • After I changed all my mailboxes in Opera Mail from POP to IMAP I stopped getting popup and sound notifications about new letters. How to fix that?

  • Popup should always be working ... it does fetch your new mail?

  • @sgunhouse said in OPERA MAIL - no notifications when using IMAP:

    Popup should always be working ... it does fetch your new mail?

    Yes, I get all new mails but no popups and no sound. The only time I see all notifications is right after the program start.

  • Close down Opera Mail and look at operaprefs.ini in the preferences folder (see "Menu > Help -> About Opera" for the location). Make sure that "Show Notification For New Messages" is NOT in there under [User Prefs]. Or, if it is there, make sure it's set to 1. Don't mess with the corresponding settings in Opera's user interface as it's broken.

    If everything is fine there, you can rename operaprefs.ini so that Opera Mail creates a new one to see if that helps. You'll then just have to readjust your global mail preferences again. Your accounts and their settings will remain.

    In "Menu -> Mail and Chat accounts -> the account -> edit -> Incoming", make sure "Play sound when new messages arrive" is checked and make sure a wav file is chosen. You can close down Opera and confirm these settings by looking in accounts.ini in the mail folder. Under the section for each account, you'll have Sound File=path_to_file and Sound Enabled=1.

    Also, if it's only working on startup, check the incoming tab in the account's properties. Make sure "Include this account when checking for new mail" is set. And, make sure the check interval is between 4 and 30 minutes so that IMAP IDLE doesn't time out.

    Besides that, there's nothing else you can check. Some users have reported that notifications just don't work for them with no way to resolve the issue. But, in those cases, no one could ever figure out why.

    @einsteinxxl said in OPERA MAIL - no notifications when using IMAP:

    After I changed all my mailboxes in Opera Mail from POP to IMAP

    By "changed", you mean you deleted the POP accounts and create new accounts that were IMAP (as opposed to just changing the server name and port to IMAP ones in the POP accounts)? As in, in "Menu -> Mail and Chat accounts", it says "IMAP" for the type?

    I assume so, just want to double-check.

  • Close down Opera Mail and look at operaprefs.ini in the preferences folder (see "Menu > Help -> About Opera" for the location). Make sure that "Show Notification For New Messages" is NOT in there under [User Prefs]. Or, if it is there, make sure it's set to 1.

    "Show Notification For New Messages" is NOT in there under [User Prefs] in my operaprefs.ini

    In "Menu -> Mail and Chat accounts -> the account -> edit -> Incoming", make sure "Play sound when new messages arrive" is checked and make sure a wav file is chosen.

    This option is checked and file is ok. Besides, as I previously mentioned, everything works great right after program start.

    Make sure "Include this account when checking for new mail" is set. And, make sure the check interval is between 4 and 30 minutes so that IMAP IDLE doesn't time out.

    I use 10 min interval.

    By "changed", you mean you deleted the POP accounts and create new accounts that were IMAP (as opposed to just changing the server name and port to IMAP ones in the POP accounts)? As in, in "Menu -> Mail and Chat accounts", it says "IMAP" for the type?

    Yes, I deleted POP accounts and created new accounts with IMAP. I know how to do that 🙂

  • Ok. Just to rule out something with your profile, you can download the Opera Mail installer, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "Standalone installation" and install. In that Opera, set up all your IMAP accounts and your sound file. If it works there, then then you know it's something messed up with your normal profile.

    If it still doesn't work right, it's probably just a bug. I guess you could try testing with standalone installations to see if it's a certain account that messes things up. As in, set up only one IMAP account to see if it works. Then another. Then another till it breaks.

    Are you running Opera Mail inside sandboxie?

    A different thing you can try to to download Opera 12 and use it only for mail as it's more stable and complete that Opera Mail. To make it like Opera Mail, goto "Alt + p -> advanced -> programs", add the http and https protocols and set them to "open with the default application" (which will be your default browser).

    If all else fails, I'd see if you can find something external from Opera (another app or security software) that's interfering with Opera.

  • @burnout426 said in OPERA MAIL - no notifications when using IMAP:

    Ok. Just to rule out something with your profile, you can download the Opera Mail installer, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "Standalone installation" and install. In that Opera, set up all your IMAP accounts and your sound file. If it works there, then then you know it's something messed up with your normal profile.

    Thanks for your advice. I did as you wrote but I got exactly the same problem with standalone installation ((
    While experimenting with account options I found out one strange thing: whatever check interval I make - all new emails come to me immediately after sending (from another mailboxes). I even unmarked this option (screenshot) but I see no affect - new emails appear immediately in Opera mail. Isn't it strange?

  • @einsteinxxl said in OPERA MAIL - no notifications when using IMAP:

    While experimenting with account options I found out one strange thing: whatever check interval I make - all new emails come to me immediately after sending (from another mailboxes). I even unmarked this option (screenshot) but I see no affect - new emails appear immediately in Opera mail. Isn't it strange?

    That's IMAP IDLE (aka push) happening there. You can turn that off by closing down Opera and editing incomingN.txt for the account where N is the number for the account as seen in accounts.ini if you ever wanted to.

  • @einsteinxxl said in OPERA MAIL - no notifications when using IMAP:

    That's IMAP IDLE (aka push) happening there. You can turn that off by closing down Opera and editing incomingN.txt for >the account where N is the number for the account as seen in accounts.ini if you ever wanted to.

    But can this cause my problem or it is normal?

  • @einsteinxxl said in OPERA MAIL - no notifications when using IMAP:

    But can this cause my problem or it is normal?

    It's normal and shouldn't cause a problem.

  • @burnout426 said in OPERA MAIL - no notifications when using IMAP:

    It's normal and shouldn't cause a problem.

    Then we should say that it is really some Opera Mail bug and I am very upset that I can do nothing with it. I love Opera Mail and I use it about 6 years already... But if I get no notifications about new incoming mails - that is very very very bad...

  • @einsteinxxl It probably is a bug. But, most don't experience it and notifications work fine.

    You don't happen to have low-bandwidth mode enabled for the account or "do not download attachments" set, do you? They shouldn't affect notifications, but you can disable them if they're enabled to see if that helps.

    You can modify the offline setting on the "incoming" tab in the account's properties. Set it to "make all messages available offline", which will make Opera always automatically download all messages in full including all existing messages, but maybe it'll work around the issue.

    In the incomingN.txt file i mentioned, you can disable QRESYNC and force a single connection to see if those help.

  • @burnout426 said in OPERA MAIL - no notifications when using IMAP:

    You don't happen to have low-bandwidth mode enabled for the account or "do not download attachments" set, do you? They shouldn't affect notifications, but you can disable them if they're enabled to see if that helps.

    Tried to turn on/off these settings - no effect.

    @burnout426 said in OPERA MAIL - no notifications when using IMAP:

    You can modify the offline setting on the "incoming" tab in the account's properties. Set it to "make all messages available offline", which will make Opera always automatically download all messages in full including all existing messages, but maybe it'll work around the issue.

    Tried this - no effect.

    As I wrote the most strange thing about this - everything works great when I start Opera Mail. I hear sound notifications and see popup notifications. But then (while the program is running), if I get new emails - no notifications at all! They just appear in the list of Unread and that's all (

  • @einsteinxxl said in OPERA MAIL - no notifications when using IMAP:

    As I wrote the most strange thing about this - everything works great when I start Opera Mail. I hear sound notifications and see popup notifications. But then (while the program is running), if I get new emails - no notifications at all! They just appear in the list of Unread and that's all (

    Any change if you minimize Opera Mail so you're not looking at it? Any change if you ctrl + alt + shift + h to minimize Opera Mail to the tray?

    Any change if you click the 'Inbox" IMAP folder view under the you@example.com access point for an account?

    I know you said only on startup, but when you manually check with the check/send button -> check all on the mail panel toolbar, what does that do as that's not an automated check?

  • @einsteinxxl said in OPERA MAIL - no notifications when using IMAP:

    (screenshot)

    Do you always have "do not make messages available offline" set? Or was that just set for testing?

  • @burnout426 said in OPERA MAIL - no notifications when using IMAP:

    @einsteinxxl said in OPERA MAIL - no notifications when using IMAP:

    But can this cause my problem or it is normal?

    It's normal and shouldn't cause a problem.

    I should mention though that if you uncheck "check messages every..." the IDLE connection will eventually time out and you won't get new messages after that unless you manually check or restart Opera.

  • @burnout426 said in OPERA MAIL - no notifications when using IMAP:

    Any change if you minimize Opera Mail so you're not looking at it? Any change if you ctrl + alt + shift + h to minimize Opera Mail to the tray?

    No changes

    @burnout426 said in OPERA MAIL - no notifications when using IMAP:

    Any change if you click the 'Inbox" IMAP folder view under the you@example.com access point for an account?

    No changes

    @burnout426 said in OPERA MAIL - no notifications when using IMAP:

    I know you said only on startup, but when you manually check with the check/send button -> check all on the mail panel toolbar, what does that do as that's not an automated check?

    If there is new email it simply gets in Unread list - no notifications at all.

    @burnout426 said in OPERA MAIL - no notifications when using IMAP:

    Do you always have "do not make messages available offline" set? Or was that just set for testing?

    I tried different variants of this setting - no effect.

    @burnout426 said in OPERA MAIL - no notifications when using IMAP:

    I should mention though that if you uncheck "check messages every..." the IDLE connection will eventually time out and you won't get new messages after that unless you manually check or restart Opera.

    I know that. I tried it just for experiment. I always use 5 min interval. Also tried 10 min but no changes for my problem.

  • OK. Are these IMAP accounts all with the same provider? If you can set up a free account with another provider and test an IMAP account with it, maybe it'll work for that one and then we can see what's up with your regular ones.

    What OS?

    How do you have your taskbar configured? Anything different than default with your systray icons?

    Trying to think of something as Notifications work fine for me for my IMAP account in Opera Mail.

    But, if you're done messing around, I'd just use Thunderbird.

  • OK. Are these IMAP accounts all with the same provider? If you can set up a free account with another provider and test an IMAP account with it, maybe it'll work for that one and then we can see what's up with your regular ones.

    No, of different. I also thought about that 😉 But they behave exactly the same.

    How do you have your taskbar configured? Anything different than default with your systray icons?

    No, standard configuration. And I changed nothing at all - just made IMAP accounts.

    What OS?
    Win 7 64x. I also use Avast Free Antivirus but I tried to turn it off completely - no changes.

    But, if you're done messing around, I'd just use Thunderbird.

    I thought about that. For the last week I tried: Mailbird, Postbox, eM Client, Mozilla Thunderbird - but I didn't like them.
    Mailbird and eM Client are great (though they cost some money) but they do not have RSS-reader. Mozilla Thunderbird has RSS reader but this program looks totally different than Opera Mail. i tried to work with it but... I can't. I so got used to Opera Mail that I think it is the most comfortable, effective and simple client in the world. Can you imagine how upset I am? Today I will install Outlook 2013 - may be it will be good.

    By the way, if Opera Mail takes about 70-80Mb of system memory, Mailbird and eM Client take 130-150 and even more Mb ((