Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

First website Opera loads after opening is super slow. Speed returns to normal once first page is displayed.

  • After opening Opera, the first website I try and open takes well over a minute to load.

    Once the first webpage has loaded, Opera returns to normal and any subsequent pages I try to open, whether it be in a new tab or new window, loads fast as usual. However, the issue returns if I close all windows and open Opera again - the first page I try to load is extremely slow.

    I have tried clean installing Opera several times, although I may be missing something in the process. Please help.

  • I just created an account to reply here. Unfortunately I cannot help, but I'm experiencing the same issue. Initially I thought it's about internet connection in general (especially because I just updated to Fall Creators Update on Win10 in my case) but other applications like Slack or Firefox (or even simple ping) work like expected.

  • Same problem. Using latest stable Opera on updated Win 10 Pro 64. Browser likewise unusable after resuming from sleep or hibernation: will not connect to any site and must be restarted. No such problems with any other browser.

  • Try with a clean profile:

    • Opera Help > Find solutions.
      | - And rename the profile folder -.

    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Opera Test profile | Opera Reset / Back up Linux · Mac · Win

  • @zalex108

    Hey, I know this thread is long past due, but I had this same problem come up. I followed all of the instructions from this thread and got no improvements. I did some more digging around and I found another solution in this reddit thread from r/operabrowser I went ahead and give it a try and it worked. I wanted to leave the link to the thread in case anybody else runs into this problem and possibly if this can be fixed from the developer side of things.

  • All opera versions ( Stable, Beta, Dev ) starts slowly for some time.

    In procmon.exe with opera.exe filter
    NotifyChangeDirectory:

    C:\Users\Username\AppData\Roaming\Opera Software\Opera Stable

    FILE_NOTIFY_CHANGE_FILE_NAME, FILE_NOTIFY_CHANGE_DIR_NAME, FILE_NOTIFY_CHANGE_ATTRIBUTES, FILE_NOTIFY_CHANGE_SIZE, FILE_NOTIFY_CHANGE_LAST_WRITE, FILE_NOTIFY_CHANGE_SECURITY

    takes up to 15 seconds during that time Opera window is white and unresponsive.

  • Just some general things you can try.

    Download the Opera installer, launch it, click "options", set "install path" to a folder (see following list), set "install for" to "standalone installation" and install. Do this for each of these paths:

    "C:\Users\yourusername\Appdata\Roaming\Opera Software\Opera Test 1"

    "C:\Users\yourusername\AppData\Roaming\Opera Test 2"

    "C:\Users\yourusername\AppData\Opera Test 3"

    "C:\Users\yourusername\Opera Test 4"

    "C:\Users\Public\Documents\Opera Test 5"

    (launching their launcher.exe in each, which should launch automatically after install)

    Test in each of those to see if there's any difference. Which ones work and which ones still have the issue might tell if it's a certain folder that has issue (security permissions or read/write issues in general).

    If no difference in any of those and they all have the problem too, create a new user account on Windows and make a standalone installation of Opera in a folder on that user's desktop to see if it works there.

    When you're all done testing, you can delete all those folders. In Windows Explorer, click "View" and make sure "hidden items" is checked.

    You can also try CrystalDiskInfo to check the health of your hard drive. If not using an SSD, you could manually defrag the hard drive with the built-in Windows defrag tool. You could also run a command prompt as administrator, enter the command chkdsk /r to schedule a scan on startup. Then, restart and let windows do a scan (can take a long time.)

    If you have another drive, try doing a standalone installation to that drive instead of C: to see if there's any difference.

    You can try disabling real-time protection in your anti-virus software temporarily just to see if it makes a difference.

  • @hispanicman15 I never posted the instructions here in case anybody did not want to head to reddit for the answer. I hope this helps!

    From User: arckmed

    Go to Internet Explorer (Yes, Internet Explorer) > Settings > Internet Options > Connections > LAN Settings > Uncheck "Detect automatically the configurations" and that should do it. Just in case anybody need it: My Windows is Windows 10 Fall Creators Update 1709.