Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • When I updated to 49.0.2725.47 (manually, because the auto update always errors), many videos now open/play instead of being the gray box that lets me decide if I wanted to play them or not.
    *Let me tell ya, videos on news articles are rather annoying, which is why I just read the articles.

    I had changed no settings. It was simply a matter of updating to the new version.

    Yes, since they have been playing, I have tried to change settings. Trying to get something to work. The best I can do is turn off flash, but that causes other functionality issues.

  • @nunya It has been a while that HTML5 has preference over Flash in Chromium and that's why you don't see the 'click to play' option, what was also removed from Opera by the way.

    To avoid video auto-play, try opera://flags#autoplay-policy or some extension.

  • @leocg
    Well, yeah, HTML5, that is why Youtube plays. I am aware of that.
    But I find it odd that multiple sites would all update to HTML5 on the same day of my update. Don't you?

  • @nunya Most probably those sites didn't update their media players, they should have been using HTML5 since a long time but sending the Flash based players to Opera.
    Since now Chromium seems to send info that there's no Flash support, those sites started sending the HTML5 based videos to Opera.