Can't delete Google from opera search engines permanently

  • I don't like Google and I don't want them as a search engine in Opera. Each time I open Opera, even though I have deleted Google from the search engines in the preferences in my last session, Google reappears as the default search engine. I deleted other search engines (like the Wikipedia search) and they never reappear - only Google. I always set an alternative for the default, but with each new session it brings back Google and makes it default again. How can I permanently take Google out of the search engine options and make sure my alternative search engine will always be the default selection?

  • You can hide the Google Search box from the Speed Dial page. I don't know that you can eliminate it as an option from the Omnisearch main address bar. But look, just don't use it. And you know, you can add search engines.

    If you want to search with something else (other than the five main potential default search engines), go to the website of the search engine (in this case let's say, duckduckgo), right click on the search bar there, and add the engine to Opera. Then right click on the address bar, go to edit search engine, and you will see the letter that goes with duckduckgo. It happens to be a d. So if you want to search with DuckDuckGo from the address bar, just type d [and your search from the address bar]. So you can search from the Opera address bar with almost any search engine, by just adding it to Opera (at the search website) (finding the initial (s) to precede your search. Dogpile is do [plus the search] (once you add it to Opera).

    Alternatively, you can add extensions that might be good for you in terms of security. If you're concerned about that, the Disconnect Search extension may be perfect for you. Whatever you type in the Search bar when you use a major search engine can only be traced to Disconnect Search, not to you. They have five default search engines (one of which is DuckDuckGo, and you can set up the one you want to operate from the main Opera Search bar. Maybe Google is still on the computer ;))) but you never have to use it, or if you do through Disconnect, the search query is private, not traced to you (or so the Disconnect Search people are saying). And through using Disconnect, you can even make DuckDuckGo a default search in the Omnibus search-address bar -- even though it is not one of Opera's default engines.

    Hope some of this might help you.

  • Ok I'm going to need some help from someone with a LOT more technical knowledge here.

    There's some background file or setting that is not only making Google UN-deleted but also reset as the DEFAULT search engine - for the search bar and the address bar. That's just horrible and unacceptable. Google doesn't need any more of anyone's information than they already get. I don't know if Opera has some creepy contract with Google or what, but none of the other search engines are behaving this way with this browser.

    I already understand the information provided to me (I have no idea why I was directed to simply add another search engine - I already explained in my first post that I did exactly that!) I use StartPage which is the only somewhat anonymous search engine on the web, and it's the only one I ever want my browser to use. I have set it to default every single time I've used Opera, and every time I start a new session, StartPage is still in the available searches but Google has reappeared as the default. It is absurd to have to manually delete Google as soon as I open up Opera every single time. Opera needs to respect my setting and stop overriding it, and I'm hoping that someone here knows how to make it do that.

    Thanks in advance to anyone with some serious knowledge in this area!!!

  • Opera pretty much used to be the safest, most secure Browser out there, but they only give you 5 choices for your search browser, Google, Yahoo, Bing, Amazon and Wikipedia, Anything else is a workaround, Doesnt really bother me that much, since I use Startpage as my homepage and only search from there anyway, but for them to allow you to change to a more secure safer Search engine instead of the information sucking Googles and the likes WOULD be a good idea

  • If you can handle another toolbar, you can get either the Startpage or Ixquick toolbar added to Opera, it isnt made for Opera but if you change your user agent to Chrome on Windows, it will install on Opera 20, Go to settings on the Startpage Search engine and youll see it on the left. heres a screenshot of what it looks like on my browser ---->

    http://s67.photobucket.com/user/ColdWinter61/media/StartpageOperaScreenshot_zps511452ed.jpg.html?sort=3&o=0

  • I think I'll keep the startpage toolbar, I'ts usefullness will more than make up for the space it takes up, you can also hide it or unhide it with a single click, since the screenshot i've changed it back to startpage from ixquick, both are excellent search engines, I fully recommend this toolbar. Update--> you can change this toolbar from either Ixquick or Startpage, they are both built in to this toolbar, It also has settings for deleting History, Cookies and stuff, Really Really Cool :)

  • The toolbar idea sounds interesting - still up for anyone else with comments on making Google stop appearing, but if no one can figure that out then I guess I'll have to try that instead!

  • @tiffany267

    I don't purport to have the technical knowledge to know why you have that Google problem, but I do use the Disconnect Search extension, which I referred to in my note to you, though at the end, so perhaps you didn't focus on it.. In my view, it is worth a try to run your Search through the Disconnect Search extension. Here's why! First, you can in the extension's settings, choose for the search to be through the main Opera address bar, obviating the need to set up a second search bar that will take up space. I do that with Disconnect (so I do have experience with it). Now Opera has five search engines. Duck Duck Go is not one of them. But when I select DuckDuckGo as my search engine in the Disconnect search extension, whenever I type a search in the Opera main address bar, DuckDuckGo is automatically used. It would appear that through the extension it has become in a sense my default, notwithstanding the general Opera setting. So I think it would be a "reasonable try" for you to set a default engine in Disconnect, other than Google, choose the setting -- if you want -- in Disconnect Search that your searches take place in the main Opera address bar, AND SEE if the crazy default problem where Google keeps coming up, disappears. I don't guarantee it will, but I have reason to think it might. Here's a link to the DisconnectSearch extension.

    https://addons.opera.com/en/extensions/details/disconnect-search/?display=en

    You're concerned about privacy and Google, so it would seem you would be intrigued/interested in the privacy claims that come from Disconnect, which have been the subject of articles in the national media. I cite two of them from you below, and then a link to the Disconnect Search website, where they have a FAQ and other information.

    http://techcrunch.com/2013/10/07/disconnect-search-built-by-ex-google-and-ex-nsa-engineers-lets-you-use-google-bing-and-yahoo-without-tracking/

    https://www.informationweek.com/mobile/mobile-applications/disconnect-search-google-in-private/d/d-id/1127885

    https://disconnect.me

    At the worst, if the search from the main Opera address remains a problem (I think it may well not) you could search from the separate Disconnect search bar, and may well have a more private search than you would have from other search bars that you might be adding to Opera.

    Best of luck with your Opera search problem!

  • Tiffanys problem is the 5 search engines you can choose for the default, he doesnt like that, he uses Startpage, he doesnt need "Disconnect", since he cant change from those 5 search engines as his default, without a workaround of some sort, I gave him or her the best option, a separate search box that is Startpage or Ixquick only, It is the best solution for that type of problem, it's my solution and I use it and recommend this solution and you dont have use the address bar for searches and you dont have to open another page or tab to access the search engine, It's just there, one click you can hide it if you want and one click and it's there

  • @colderwinters

    Gotcha. I missed that Startpage part. Startpage is not one of the default search engines in Disconnect Search. If that's the one Tiffany wants to use, then Disconnect Search doesn't help, although Disconnect is also supposed to further making the search anonymous. Disconnect Search only works if you user is willing to select one of the five search engines that work with their extension. So your approach definitely seems the most promising.

  • Thanks for trying, I guess... I'm still hoping someone will contribute an answer to my actual question, but I'm starting to wonder if there's no one on the forums who can...

  • You can't remove it, no. Built-in searches can't be removed. Set something else as default and just don't use Google.

  • You might find this link interesting.
    https://productforums.google.com/forum/#!topic/chrome/xJURG2e8h8U[1-25-false]

    Someone complains why Conduit Search keeps hijacking their Chrome default search engine. The best answer seems to be by Sie_Deen: this "change is usually caused by a 3rd party software." A few suggestions are provided, which you might want to look at. Now the main commenter at the link suggests if all else fails resetting the Chrome browser. Here's a link on how to reset the Opera browser, and involves deleting the Operapref.ini file I've never done it myself :) but it's a thought, and seems to follow from the commenter's idea. Since it would delete all of your preferences, maybe you could save it somewhere, and restore it later, if the deleting accomplishes nothing.

    http://en.kioskea.net/faq/6361-reset-your-browser-restore-your-browser-to-default-settings#how-to-reset-opera

    This isn't discussed at the link, but you might want to look at your cookies -- settings/privacy and security/cookies/all cookies and site data. Have you tried clearing them, or google related ones?

    Anyway, that's about all I can think of on this crazy problem.

  • Oh, thanks - the Operapref.ini part sounds interesting! Thanks!

  • Hope it all works out for you, tiffany :)

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.