why does ctrl + enter refresh the page?

  • I'm used to press ctrl + enter in order to send form data without clicking the send button.
    Since version 21, ctrl + enter will refresh the page instead of submit the form.

    Is there a setting where i can control the behavior of ctrl + enter in opera?

    edit:
    ctrl + enter works with other browsers, so it seems it's an opera issue.
    Even on this very forum will ctrl + enter pressed while i'm in the "edit discussion" mode reload the page instead of sending the data(And with this loose all data i've entered).

  • Left Ctrl + Enter opens find in page here. However it does nothing on some pages.

  • In Opera 12, Ctrl+Enter was the same as the Wand (login) button ... not sure about other uses though.

  • Is there a way to see how keyboard shortcuts are configured in opera next?

  • Hi Suntsu42, you can find the default key bindings in the "opera.pak" file, which is located in the Opera's root subdir - in the latest Opera Next, it is located in the "21.0.1432.39" subdirectory.

  • Hi I33t4opera,

    I found the "Keybindings" in opera.pak, but it seems this combination is not bound to what i would expect.
    The following binding is set: "PastePassword": ["Enter+Ctrl"],

    But one question:
    If you're entering text right here in this forum, and then press "CTRL + Enter", does it save the entered text or does it refresh the page?
    On my opera, it only refreshes the page.

  • I have the same problem. Also "ctrl+backspace" does not delete last typed word, but makes browser go to previous page.

  • Hi Fix-kun, to get rid of this issue, you can simply remap the keyboard shortcut for the "ParentDirectory" "Ctrl+Shift+Backspace" as follows:

    1. Close the Opera, and go to the Opera's profile (find the path in: O-Menu>About Opera>Paths>Profile),
    2. Open the "Preferences" file in your text editor, and edit it as below:
    {
       "Keybindings": {
          "Basic": {
             "ParentDirectory": [ "Ctrl+Shift+Backspace" ]
          },
          "Settings": {
             "AdvancedEnabled": true
          }
       },
    
    1. Save the changes, relaunch the Opera.
Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.