How to stop Opera resetting as the default PDF reader every time I restart my computer

  • I've tried checking the box in Opera Settings to open PDFs in the default program. I've tried setting another program (PDF-Xchange Editor) as the default PDF program. I've tried selecting (PDF-Xchange Editor) to open the PDF file type. I've tried checking "Always use the selected program to open this kind of file".

    Nothing seems to work. Every time I restart my computer, Opera resets itself as the default PDF program.

    Any suggestions would be very much appreciated.

  • No ideas, anyone ? Oh well, I guess I'm stuck with it.

  • In Opera's settings there is an option to use external programs to read PDFs, maybe you can enable it although I don't really think it will make any difference.

  • Thanks very much for your reply.

    Do you mean checking the box in Opera's Settings to open PDFs in the default program which I mentioned above, or another option somewhere in Opera's Settings ?

  • Do you mean checking the box in Opera's Settings to open PDFs in the default program which I mentioned above

    Yep. Sorry, missed that.

  • Okay. Thanks again for your replies.

    Looks like I'm stuck with it unless anyone else has any suggestions. I wonder if it's the same for everyone else ?

  • The default program worked for me. Although, I also had to select Opera as my main browser in order for that to work. You could also right click any pdf, select properties, change opens with to Opera. That should solve the problem.

  • Thanks very much for your reply, gabrieljonathan123.

    However, I'm trying to stop Opera from resetting itself as the default PDF program every time I restart my computer.

    I can right-click a pdf and then select PDF-Xchange Editor as my preferred PDF program, and that works fine until I restart my computer. Then Opera resets itself as the default PDF program, every time.

  • I'm having the same problem and it's been going on for a long time. Opera wants to D/L pdf files if it is not set as the default to open PDF files and it's a pain. I reported the bug back in July and the said to go check the settings. Responded telling them their "fix" didn't work and that I had checked it out before I sent the bug report.

  • If you are using another program to read PDFs, then they will have to be downloaded. You can't read something you don't have. (Even when you read it in Opera it is downloaded, lust it is in the cache instead of your Downloads folder.)

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.