Opera 45 slow video playback especially with youtube

  • Hi, since Opera 45 the video playback is slow especially with youtube, and some frames seems to break. With Opera 44 the playback was smooth even with video pop out (video played in a separate window).
    I have an Athlon 5000+ with an onboard nvidia video card that I use only for browsing and youtube and it worked well until Opera 45. I tried to disable the 'Battery saver', or the 'Use hardware acceleration when available' in settings but the problem remains. If I install opera 44 everything works again but it autoupdates itself very quickly.
    So my question is: Can I disable something inside Opera, to go back to version 44 playback functionality, or I'll have to stay with opera 44 (by deleting 'opera_autoupdate.exe')?

    Thanks.

  • Welcome to Opera's forums @Onlyra!

    I would recommend you to test V45 in a portable installation, but in another directory, to test it as a clean install and check if the problem still happens.

    Depending on the result start over to set your profile in V45 or keep yourself in the V44 until the next update.

  • Thank you, the problem remains even with a fresh install of opera 45(after deleting profile files) so
    馃槓 version 44 is for me

  • Any newer drivers?
    Maybe helps.

    At the other hand, You may try with OBeta and/or ODeveloper, and depending on the result report it.

    There is a post where a video located into One drive doesn't work in OStable but work fine in OBeta.

  • I have la latest drivers (2015) for that onboard videocard. Its a Win7 - 64 bit system with 4GB RAM.
    With Opera Beta 46 or Opera 45 portable (so a new profile) and the problem is still there even at 480p. Tried a fresh Windows 7 (I had a backup). No change.
    With Google Chrome Portable 59.0.3071.86 youtube plays nice even if I play multiple tabs with different videos.

  • Try toggle On/Off Hardware Acceleration on Settings.

    And also if needed, type Opera://Flags
    And enable Override software rendering list


    Windows 10 (x64) | Aniversary Update
    Opera Stable 路 Beta 路 Developer

    Test profile | Back up LinuxMacWin

  • I agree, there appears to be a problem with v45.0.2552.898 for video playback which is no longer smooth and is forever buffering. Same version used on two machines, one running "Windows 7 Pro", the other "Windows 10". Same issue on both machines. A friend suggested I may not have enough memory to cope with it, to which I pointed out I had massive amounts of memory which had not changed since the previous Opera version!!! Opera is great as Opera fans all know, but the latest version does appear a touch screwed up. Opera will however remain my default browser, but it should be noted by Opera developers that I have ZERO problems with video playback using IE (but I would prefer not using IE).

  • Additional info to my post -- I've tried a clean install of Opera by deleting all Opera content, then closed browser (on both my machines), cleaning them up at the same time - (scan and defrag). Downloaded clean Opera browser from official Opera site using IE (on both machines), and video playback issue is still apparent. Hope this info helps the Opera Team.

  • Same problem here, upgraded opera to 45 version and now those videos I stream with Opera are very slow. Videos work great on Mozzilla or Chrome. CCleaner, turning off VPN, delete cookies.... nothing worked for me

  • Same here, disabling Hardware Acceleration is not a solution.

  • Sorry for my absence, I'm back now.
    With Opera 45 portable - I disabled Hardware Acceleration on Settings and enabled Override software rendering list. Now the frames don't seem to break anymore but video is still behind audio, out of sync, in normal window and also with video pop out. So still not fixed.
    But I noticed something else. If I watch youtube in a video pop out and I minimize Opera(or at least move youtube to a New window and minimize that window) the playback in the video pop out is miraculously very smooth. At least as long as youtube is minimized.
    So bad playback in normal window and with the pop out, good playback in a pop out with opera or youtube window minimized. And this happens even with a 480p video

  • There is a new Update, Opera 46, try it, maybe fixes your problems.


    Windows 10 (x64) | Anniversary Update
    Opera Stable 路 Beta 路 Developer

    Test profile | Back up LinuxMacWin

  • I disabled Hardware Acceleration on Settings and enabled Override software rendering list.

    Did you try enabling hardware acceleration again?

  • I'm having the same problem with Twitch as well. frames drop like flies. It's specific to Opera (appeared in Opera 45, wasn't there before), as watching in another browser (Sea Monkey in my case) doesn't create this problem.

    Disabling Hardware acceleration doesn't make it any better. New Opera 46 doesn麓t fix the problem, which seems to happen with 60fps videos.

    Watching in full screen seems to make it more bearable, though.

  • With Opera 46 I have the same problem.
    I also noticed that if I switch to full screen the youtube(or vimeo..) video playback becomes very smooth, just like when I minimize Opera but the video pop out remains.
    So I don't think it's the hardware acceleration, maybe some 'layer' added since opera 45.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.