YouTube region content automatically set to 'India', can't change it.

  • Hello all, won't make it too long. I'm from South America, specifically Argentina, usually making YouTube logo appear with "AR" next to it, indicating that I'll be tailored things from my country or in best cases only things related to other things I've liked or follow. The problem is that for some reason I still don't know, in Opera (and only Opera, not other browsers) YouTube is set to "IN" which is India. If I go down on YouTube and manually change the region, it will change only until I close the tab. If I do this an re-open YouTube again, it will be "IN" once again. Like if it resets and for whatever reason with Opera reads I'm from/in India. How do I solve this? Is there any way?
    I've already uninstalled and reinstalled, cleared cache from browser and with Ccleaner... no solution. Thank you very much.

  • Do your search results come up in in www.google.co.in or whatever the Indian version of Google is? Trying to decide if it is in Opera or YouTube ...

  • Make sure you're signed into your YouTube account then go to 'YouTube' > 'Settings'. In very small letters on the page somewhere, you'll find 'Advanced'. Click that and down the very bottom of the page, you'll find 'Country Selection'. Change it there.

  • I too had this problem the other day. I managed to resolve it by clearing YouTube’s cookies and going to www.youtube.com.ar which redirects you to youtube.com in the right language. (Ensure you leave no tabs open as you delete the cookies, since they are placed and modified on page exit too.)

  • Make sure you're signed into your YouTube account then go to 'YouTube' > 'Settings'. In very small letters on the page somewhere, you'll find 'Advanced'. Click that and down the very bottom of the page, you'll find 'Country Selection'. Change it there.

    That isn't under advanced. See screenshot: http://prntscr.com/fhuhiu

  • The screenshot only shows Channel settings; where's the rest?

  • I too had this problem the other day. I managed to resolve it by clearing YouTube’s cookies and going to www.youtube.com.ar which redirects you to youtube.com in the right language. (Ensure you leave no tabs open as you delete the cookies, since they are placed and modified on page exit too.)

    Hey, I want to let you know that you can access the right region in this case because you are putting ".com.ar" at the end. If I go to "youtube.com" it will direct me, again to IN region (India). If I put "youtube.com.ar" will direct me to the "Youtube.com" AR region. So it's not because the cookies.

    I guess adding "youtube.com.ar" as favorite in speed dial will be the solution.

  • Do your search results come up in in www.google.co.in or whatever the Indian version of Google is? Trying to decide if it is in Opera or YouTube ...

    Google search does search under .com.ar URL. Other websites track my location fine as well.

  • @latisullivan Yes, that is the exact issue I was having. You must ensure to start fresh. Close all YouTube tabs and clear YouTube’s (and Google’s) cookies from Opera’s settings. Then visit youtube.com.ar which places the right cookies. You could then visit youtube.com as you remain in the AR region.

    You may not have closed all YouTube tabs prior to clearing the cookies before.

  • And if Google trying to tell you something..? :lol:

  • Same issue. Tried the cookies fix and it worked for a couple of days.... then just now went back to India for some reason.

    • VPN is turned off
    • Region should be set to US
    • Deleted all cookies and history (through Opera AND using CCLeaner)

    ¯_(ツ)_/¯

  • I live in the UK and yet Youtube defaults its content setting to India while browsing via Opera on windows. I don't get the same issue using Firefox. Looks like the problem is on Opera side rather than my local machine.

  • Further to my last post, I now understand the issue even more.

    When I access Youtube, either through typing www.youtube.com in the address bar or bookmarks, then it will correctly default to the UK for its content setting since I'm based in the UK.

    When I access Youtube through the youtube icon on speed dial then it will wrongly default to India for its content setting.

    If you access Youtube via speed dial first and then later either, through typing www.youtube.com in the address bar or bookmark, then it will still keep the default content setting to India unless you clear the cookies prior.

    So the solution is for Opera to fix the Youtube geographic setting in fast dial as Youtube settings behaves normally if you access it only through bookmark/address bar. It could be a coding issue or the server for fast dial might be located in India hence why Youtube defaults to India. I hope Opera fixes this issue as it is extreme annoying to keep constantly correcting the content setting location to UK after using fast dial.

  • Just to add: I'm on windows 7 and using Opera Version 46.0.2597.26 (PGO)

  • I'm also on 64 bit.

    Is there an edit function on your forum?

  • Is there an edit function on your forum?

    Yes, but has a 30 minutes limit.

  • Is there an edit function on your forum?

    Yes, but has a 30 minutes limit.

    Okay, but my posts are awaiting moderation which means I'm not able to see the edit function.

  • I think I found a work around the problem of Youtube setting its contents to India.

    1. Delete the Youtube icon from speed dial.
    2. Navigate to youtube through the combined address and search bar.
    3. Set your content location to your desired place in youtube.
    4. Save Youtube to speed dial.
    5. The issue of Youtube setting the contents to India should disappear.

    It seems the default youtube icon in speed dial had its contents set to India.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.