How to prevent opera to create urls from terms written at the address bar?

  • I only search for anything by simply typing the search term on the address bar of a new tab. The problem is that sometimes Opera turns those terms into a URL. For example: I just tried to search "urban dictionary ymmv" and opera turned it to " http://www.urban%20dictionary%20ymmv.com/ " which was sent to " https://www.google.com.br/search?client=opera&q=http%3A%2F%2Fwww.urban%20dictionary%20ymmv.com%2F&sourceid=opera&ie=UTF-8&oe=UTF-8 ". This is pretty stupid and frustrating sometimes. I've also been redirected to some websites a few times that have nothing to do with what I was searching and I worry I might get in trouble someday for inadvertly being redirected to a a nsfw website while at work. You can see why this worries me.

    How do I turn this function off without turning autofill predictions off? For example: when I want to go to facebook, it shows the whole facebook.com while typing.

    Any help will be much appreciated.

  • If you type words on address bar, Opera will sent them to the default search engine and show a page with the search results but Opera will not try to turn those words into a link.

    I've also been redirected to some websites a few times that have nothing to do with what I was searching

    It may be a sign of a malware infection.

  • I don't see the purpose of a malware to turn "urban dictionary ymmv" into that google search link I mentioned on my first post.

    This has got to be some kind of browser configuration.

  • What I'm trying to say is that Opera does not do it so it has to be being done by some third part.

    Do you use any extensions? If so, did you check with them disabled?

    I don't see the purpose of a malware to turn "urban dictionary ymmv" into that google search link I mentioned on my first post.

    This would be the regular behavior of Opera as I said. However, turning 'urban dictionary ymmv' into a 'http://www.urban dictionary ymmv.com/' link wouldn't.

  • That happens when you hold Ctrl as you press Enter. There is currently no way to disable or change this behaviour.

    They have given us customisable keyboard shortcuts for everything except this very annoying one.

  • That happens when you hold Ctrl as you press Enter. There is currently no way to disable or change this behaviour.
    They have given us customisable keyboard shortcuts for everything except this very annoying one.

    I knew there was something about it! I don't remember pressing ctrl when this happened so IDK what caused it but it is nice to know that I was not going crazy.

    Thank you! I'll keep this in mind.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.