VPN Slow to connect. IF it connects.

  • Version: 45.0.2552.635 (PGO) - Opera is up to date
    Update stream: Stable
    System: Windows 10 64-bit (WoW64)

    I love the browser and the new features but not having the VPN connecting and working properly makes me default back to Chrome. I would prefer to use Opera as default but need the VPN to work correctly.

    Anyone else having issues?

  • I just got the 'Creators' update for Windows 10 and now my built in Opera VPN service wont connect at all. Sounds like the same boat you're in.. and like you, the VPN is the primary reason I use Opera. If its not working, Chrome has a broader base of addons to work with.

  • I have no problems connecting to the VPN here.

    Did you try to delete third part data?

  • VPN won't connect here also. Using Version 45.0.2552 with Windows 7 Pro x64 stable. Just started having the problem about an hour ago. How to check "third part data"? Where would I find that?

  • How to check "third part data"? Where would I find that?

    In settings > delete private data.

  • Must have been a 'glitch' of some kind. It's back on now. Lasted a couple of hours. Weird.

  • For me VPN hasn't been working for the last day.

  • I'm on the latest build of Opera 42 now, on Windows 7x64.

  • VPN says "Authentication credentials required" now. is this a known issue?

  • Today, May 17, 2017 at around 7 PM GMT, VPN is no longer working on two different machines.

    I use Opera 45.0.2552.812 64-bit on Windows 10 Pro (Creator's Update).

  • Mine is down again, along with many other people..... I wonder if maybe the servers VPN contacts are affected by the WannaCrypt bull s$$$?!

  • Seems to be working now

  • May 17, 2017 - I have windows 10 Creators. The Opera VPN doesn't work today. I redownload the Opera's latest version (windows. computers) but the VPN wont work. sites like CNN/Google rerun the following msg - 'Authentication credentials required.'

  • Still not working for me. Cleared ALL browsing data from "the beginning of time". On version 45.0.2552.812 (PGO) / Windows 7 64-bit.

  • We shouldn't have to be clearing this, tweaking this, turning around 4 times and scratching our elbow while saying a mantra, etc etc to get a built in VPN working...especially when the mobile app opera vpn works considerably better.

  • I too have a problem opening a website with VPN enabled.
    After a reboot it works but if I close the browser then reopen it, I get this problem.
    I am running Windows 10 Creators Edition on a 64 bit processor.
    VPN was the only reason I moved to Opera.
    Come on Opera. Fix the problem if you don't want me to go back to Microsoft Edge.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.