[Solved] Impossible to display the Desktop Notifications

  • Hello everyone,

    I'm a new user of Opera. I have a problem with the desktop notifications: I would like to activate them, but when I receive a message, no pop-up windows is displayed.

    For information, I tested it with Discord (https://discordapp.com), a chat website, and with gmail.
    I tried the 2 options in the parameters of Opera : first the recommended one ("ask me when a website try to display desktop notifications", and I manage the exceptions to allow Discord and Gmail; then I tried "authorize all websites to display dekstop notifications". The two were unsuccessful.

    I tried the same with Chrome and Firefox, and this time, no problem: I have a small windows displaying on the right bottom corner of my screen.

    I use Windows 10 and last Opera version (45.0.2552.635)

    I really would like to keep Opera but this function is very important to me.
    Thank you for your help

  • Hello :)
    I just take the subject up, just in case.
    Thanks for your answers

  • It's probably a bug or a feature not implemented yet.

  • It works fine for me. Have you checked if Opera has the permissions to display them?

    Press Start and type ‘app notifications’; from the newly opened window, scroll down to locate Opera and confirm if it is enabled.

  • It was temperamental for me in O44, I would have to go to Settings (in Opera) > Websites > Notifications > Manage exceptions... > Finished. Basically just opening the Notifications part of Settings to "awake" that element of Opera. Then Notifications would work on YouTube, for example.

    Now with O45, nothing works. Not WhatApp nor any site. They most I get is beep & red dot on WhatsApp icon. No pop-up nor Windows toast notifications in Action Center, nothing. I've checked all settings in the OS too.

  • @luca786toni Windows 10 has had numerous problems displaying desktop notifications from apps properly since forever. The recent major update to Windows appears to have resolved it for me. You may simply have to update Windows assuming that you have already confirmed Opera is allowed to display notifications from Windows’ settings.

  • where is this magic start button and a place to type that in im on windows 10

  • where is this magic start button and a place to type that in im on windows 10

    The very bottom left corner of your screen, the icon the that looks like a window, it's the same position in all versions of Windows. Once you click on it just start typing, don't worry about anything else.

  • Thank you for your answers :)

    @tufuzay : I didn't know about this parameter in Windows 10 ! Unfortunately, I checked and Opera notifications are allowed, so the problem is not there.

    For information, a friend of mine is using Discord (the site where I want theses notifications) and Opera, but for Mac, and it is working for him. We compared all of our parameters on Discord and Opera, without any success.

  • @ifuldrita I am sorry to hear you have not been able to resolve it.

    There appears to be a minor update (45.0.2552.812) to Opera which may have addressed the issue you are having.
    Have you tried unticking ‘Use hardware acceleration when available’ from Opera’s settings to see if it is GPU-related?
    Have you tried updating Windows? The recent major update has fixed the desktop notifications problems that I used to have.

  • I'm having the same issue on Linux, and am already using version 45.0.2552.812.

    I have tried with the hardware acceleration on and off, and have also tried with both Pushbullet and GMail, but none of these display desktop notifications from Opera.

    Desktop notifications are working from both Firefox and Chromium under my current setup, so I know that they should be supported.

    I am happy to carry out any additional testing required to help diagnose the issue.

  • It worked !
    @tufuzay : I did all at the same time : update of Opera, update of Windows and deactivation of the "Use harware acceleration when available".
    I don't know which of the three was useful (I think it was the deactivation of the "Use harware acceleration when available", because four days ago both Windows and Opera were up to date), but now I have the notifications !
    I will proceed with some more tests to tell the community what was the effective solution, and come back as soon as I know :)
    Thanks a lot for your kind and fruitful help !

  • I finally identified where was the problem: the Windows 10 notifications icon (in the very right bottom corner of the desktop) was in position "Do not disturb" (that you can activate and deactivate by right-clicking).
    Apparently, Opera is totally linked with it (which is not the case for Chrome or Firefox).

    I did not even know that there were a "mute" option on this !

    Now that my problem is solved, I would like one more time to thank you all for your kind help !

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.