Java & Flash Player; how to get them to work with Opera v12.18?

  • I have installed the latest version of Java. I haven't tried Flash Player yet, but the problem has always been how to get Opera to 'see' both programs??

    I need both for the "SpeedTest" site to troubleshoot Internet jitter issue using VoIP. I don't see anything under preferences other than JavaScript which is another animal.

    Input?

  • There used to be a 'plugin' folder where you would put a np*.dll file that you can get from Flash/Java installation folders.

  • Is npjp2.dll the one for Java??

    I can't find any 'Flash' folder in Program Files or Program Files (x86). I'm running Win7

  • Ok, found it.

    Is 'FlashUtil32_25_0_0_148_Plugin.dll' the one for Flash??

  • I checked Plugins under Tools/Advanced/Plugins and both Java & Shockwave Flash show, but the site test still doesn't show. It doesn't in FF either.

    Here is the site:
    http://phonepower.com/speedtest

  • Has worked anytime?

    Mask or identify as FF?

  • Are Flash and Java recognized in their own sites?

  • Make sure you have downloaded the version of Flash which is listed for Firefox - the plugin for Chrome and current versions of Opera will not work with Opera 12.

  • Ok, Flash was verified working from two different verification sites. I beleive I have Opera ID'ed as Opera, but I forgot where that setting is. I couldn't find it under Preferences or using 'opera:config'.

    Java is not.I read Java is on the way out. I sent a e-mail to PhonePower (formally Broadvoice) telling them they need to abandon the 'Titanic'. At least two other sites appear to test what they are looking for w/o Java.

  • Java hasn't worked in Opera 12 for quite a while.
    The last version that works "out of the box" with no messing around is Java 7 Update 67.
    Java 8 Update 66 is the last that will work if you substitute the npjp2.dll file with the one from Java 7 Update 67, but I wouldn't vouch for the security status of that configuration.
    :)

  • How about just using the older version instead of swapping files??

  • How about just using the older version instead of swapping files??

    I suppose it's complementary information. :)

  • Huh??

  • It just depends on whether you think using a version of Java 8 with one substituted file from Java 7 is going to be more secure than just using a Java 7 version, which is now pretty old!
    If you use Java anywhere else, such as in Internet Explorer, then obviously the former is preferable.
    :)

  • If a choice is involved, always choose the latest version of Java that can be run on the system successfully. The number of security flaws present in any older-numbered Java version compared with any newer-numbered version is truly breathtaking, regardless of the versions being compared.

    That said, and as you probably already know, most security experts recommend removing Java entirely from general-purpose systems because of Java's constantly-appearing and serious security problems, with new problems being discovered as fast as old ones are patched.

    If one absolutely must have Java access in a web browser for accessing a specific site, some experts (Brian Krebs, etc) recommend only allowing Java access via a single Java-enabled web browser on a system, and only ever using that specific browser on known-safe sites that require Java enablement. General web browsing should then always be done with a different web browser that possesses no Java functionality, in order to minimize exposure to the vast number of Java drive-by exploits existing in the wild.

  • Thanks for all the input. Bottom line, that one site was the only one that needed Java that was a issue here. AFAIC, it's just too much hassle to bother troubleshooting on something I haven't needed just because one lame site and VoIP provider chose to use if for testing when other sits appear to have similar tests and don't need Java.

    I did express this to PhonePower(Broadvoice). They have sent me trace route charts showing where a problem maybe from my ISP (which is now Spectrum).

  • I went to Nvidia's driver download site only a couple of weeks ago, and was amazed to find that their automatic system for determining the correct driver for your system is still Java-based!
    :eek:

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.